summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorVarad Gautam <varadgautam@gmail.com>2017-04-26 19:17:18 +0530
committerDaniel Stone <daniels@collabora.com>2017-06-12 10:38:03 +0100
commitf7b3a396253b175703952588692266897af22843 (patch)
tree9b1cdd189b74771641160ea9cb62970931b78ad2 /Makefile.am
parentf9dec67990a54afe14d4d2db694bf696ae418bcd (diff)
downloadweston-f7b3a396253b175703952588692266897af22843.tar.gz
weston-f7b3a396253b175703952588692266897af22843.tar.bz2
weston-f7b3a396253b175703952588692266897af22843.zip
clients/simple-dmabuf-drm: add freedreno support alongside intel
abstract drm specific bits to struct drm_device and support running on freedreno. introduce 'modifier' event. v2: rebase to master, deprecate 'format' event. Signed-off-by: Varad Gautam <varad.gautam@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 79bd744e..2a285480 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -634,7 +634,7 @@ nodist_weston_simple_dmabuf_drm_SOURCES = \
protocol/linux-dmabuf-unstable-v1-protocol.c \
protocol/linux-dmabuf-unstable-v1-client-protocol.h
weston_simple_dmabuf_drm_CFLAGS = $(AM_CFLAGS) $(SIMPLE_DMABUF_DRM_CLIENT_CFLAGS)
-weston_simple_dmabuf_drm_LDADD = $(SIMPLE_DMABUF_DRM_CLIENT_LIBS) libshared.la
+weston_simple_dmabuf_drm_LDADD = $(SIMPLE_DMABUF_DRM_CLIENT_LIBS) $(LIBDRM_PLATFORM_LIBS) libshared.la
BUILT_SOURCES += protocol/linux-dmabuf-unstable-v1-client-protocol.h
endif