summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorVarad Gautam <varad.gautam@collabora.com>2016-11-17 17:25:59 +0530
committerDaniel Stone <daniels@collabora.com>2017-06-12 10:37:38 +0100
commitf9dec67990a54afe14d4d2db694bf696ae418bcd (patch)
treed79df373974a228266db9e910a08bfe7b906e4b1 /Makefile.am
parentc32e05bbf3bdef6007156146a8dab01770674e38 (diff)
downloadweston-f9dec67990a54afe14d4d2db694bf696ae418bcd.tar.gz
weston-f9dec67990a54afe14d4d2db694bf696ae418bcd.tar.bz2
weston-f9dec67990a54afe14d4d2db694bf696ae418bcd.zip
clients/simple-dmabuf-intel: rename to simple-dmabuf-drm
this will allow adding other drm backends later. Signed-off-by: Varad Gautam <varad.gautam@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 45df7fea..79bd744e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -623,18 +623,18 @@ weston_simple_egl_CFLAGS = $(AM_CFLAGS) $(SIMPLE_EGL_CLIENT_CFLAGS)
weston_simple_egl_LDADD = $(SIMPLE_EGL_CLIENT_LIBS) -lm
endif
-if BUILD_SIMPLE_DMABUF_INTEL_CLIENT
-demo_clients += weston-simple-dmabuf-intel
-weston_simple_dmabuf_intel_SOURCES = clients/simple-dmabuf-intel.c
-nodist_weston_simple_dmabuf_intel_SOURCES = \
+if BUILD_SIMPLE_DMABUF_DRM_CLIENT
+demo_clients += weston-simple-dmabuf-drm
+weston_simple_dmabuf_drm_SOURCES = clients/simple-dmabuf-drm.c
+nodist_weston_simple_dmabuf_drm_SOURCES = \
protocol/xdg-shell-unstable-v6-protocol.c \
protocol/xdg-shell-unstable-v6-client-protocol.h \
protocol/fullscreen-shell-unstable-v1-protocol.c \
protocol/fullscreen-shell-unstable-v1-client-protocol.h \
protocol/linux-dmabuf-unstable-v1-protocol.c \
protocol/linux-dmabuf-unstable-v1-client-protocol.h
-weston_simple_dmabuf_intel_CFLAGS = $(AM_CFLAGS) $(SIMPLE_DMABUF_INTEL_CLIENT_CFLAGS)
-weston_simple_dmabuf_intel_LDADD = $(SIMPLE_DMABUF_INTEL_CLIENT_LIBS) libshared.la
+weston_simple_dmabuf_drm_CFLAGS = $(AM_CFLAGS) $(SIMPLE_DMABUF_DRM_CLIENT_CFLAGS)
+weston_simple_dmabuf_drm_LDADD = $(SIMPLE_DMABUF_DRM_CLIENT_LIBS) libshared.la
BUILT_SOURCES += protocol/linux-dmabuf-unstable-v1-client-protocol.h
endif