summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7154e246..ceb644d12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -901,6 +901,13 @@ if test $withval = yes ; then
LIBS="$LIBS -ldmalloc"
fi
+withval=no
+AC_ARG_WITH(efence, [ --with-efence build with efence debugging support ])
+if test $withval = yes ; then
+ AC_DEFINE(EFENCE, 1, [Build with libefence support?])
+ LIBS="$LIBS -lefence"
+fi
+
AC_CHECK_FUNCS(setlocale)
dnl XXX Solaris <= 2.6 only permits 8 chars in password.