summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjbj <devnull@localhost>2002-08-19 22:27:44 +0000
committerjbj <devnull@localhost>2002-08-19 22:27:44 +0000
commitae8428475cbfde3af746d51a056e0655fe6269d8 (patch)
tree6d173ac13fbc11799ea49d3dd70d5b8ee452283a /configure.ac
parent105f7a517cd13b7c40b359548a9c75cbd00ed9c4 (diff)
downloadrpm-ae8428475cbfde3af746d51a056e0655fe6269d8.tar.gz
rpm-ae8428475cbfde3af746d51a056e0655fe6269d8.tar.bz2
rpm-ae8428475cbfde3af746d51a056e0655fe6269d8.zip
- add --with-efence to configure, check install/upgrade with efence.
- beecrypt: short hex string conversion overflows target buffer. - mark "successors only" packages in transaction. - reap scriptlets with SIGCHLD handler. - rename PSM_t to rpmpsm, add methods and refcounts to manage. - remove %%configure/%%makeinstall from arch-os/macros, default is OK. - don't export MALLOC_CHECK_ to scriptlets. - squeaky clean memory leak checking. - always malloc rpmfi structure, refcounts are correct in rpmtsRun(). - skip redundant /sbin/ldconfig scripts on upgrade (if possible). CVS patchset: 5645 CVS date: 2002/08/19 22:27:44
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7154e246..ceb644d12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -901,6 +901,13 @@ if test $withval = yes ; then
LIBS="$LIBS -ldmalloc"
fi
+withval=no
+AC_ARG_WITH(efence, [ --with-efence build with efence debugging support ])
+if test $withval = yes ; then
+ AC_DEFINE(EFENCE, 1, [Build with libefence support?])
+ LIBS="$LIBS -lefence"
+fi
+
AC_CHECK_FUNCS(setlocale)
dnl XXX Solaris <= 2.6 only permits 8 chars in password.