summaryrefslogtreecommitdiff
path: root/ext/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ext/CMakeLists.txt')
-rw-r--r--ext/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/ext/CMakeLists.txt b/ext/CMakeLists.txt
index b8917a2..edc2b9f 100644
--- a/ext/CMakeLists.txt
+++ b/ext/CMakeLists.txt
@@ -126,6 +126,11 @@ IF (ENABLE_RPMMD OR ENABLE_SUSEREPO OR ENABLE_APPDATA OR ENABLE_COMPS OR ENABLE_
solv_xmlparser.c)
ENDIF (ENABLE_RPMMD OR ENABLE_SUSEREPO OR ENABLE_APPDATA OR ENABLE_COMPS OR ENABLE_HELIXREPO OR ENABLE_MDKREPO)
+IF (ENABLE_ZCHUNK_COMPRESSION)
+ SET (libsolvext_SRCS ${libsolvext_SRCS}
+ solv_zchunk.c)
+ENDIF (ENABLE_ZCHUNK_COMPRESSION)
+
SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
IF (HAVE_LINKER_VERSION_SCRIPT)
SET (CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} ${LINK_FLAGS} -Wl,--version-script=${CMAKE_SOURCE_DIR}/ext/libsolvext.ver")