summaryrefslogtreecommitdiff
path: root/ext/CMakeLists.txt
diff options
context:
space:
mode:
authorDongHun Kwak <dh0128.kwak@samsung.com>2018-12-04 14:04:28 +0900
committerDongHun Kwak <dh0128.kwak@samsung.com>2018-12-04 14:04:32 +0900
commite679b515eddb3dd340fb25620de0160211f40fdc (patch)
tree93271e0bbd40dba805f8270cfc78a3ac10ab2c8f /ext/CMakeLists.txt
parentd98199487aa414cb7f965a058c4395235343e20a (diff)
downloadlibsolv-e679b515eddb3dd340fb25620de0160211f40fdc.tar.gz
libsolv-e679b515eddb3dd340fb25620de0160211f40fdc.tar.bz2
libsolv-e679b515eddb3dd340fb25620de0160211f40fdc.zip
Imported Upstream version 0.6.35upstream/0.6.35
Change-Id: Ib7359aa10c08c1469105fbd6a82ea922f46f8b51 Signed-off-by: DongHun Kwak <dh0128.kwak@samsung.com>
Diffstat (limited to 'ext/CMakeLists.txt')
-rw-r--r--ext/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/ext/CMakeLists.txt b/ext/CMakeLists.txt
index b8917a2..edc2b9f 100644
--- a/ext/CMakeLists.txt
+++ b/ext/CMakeLists.txt
@@ -126,6 +126,11 @@ IF (ENABLE_RPMMD OR ENABLE_SUSEREPO OR ENABLE_APPDATA OR ENABLE_COMPS OR ENABLE_
solv_xmlparser.c)
ENDIF (ENABLE_RPMMD OR ENABLE_SUSEREPO OR ENABLE_APPDATA OR ENABLE_COMPS OR ENABLE_HELIXREPO OR ENABLE_MDKREPO)
+IF (ENABLE_ZCHUNK_COMPRESSION)
+ SET (libsolvext_SRCS ${libsolvext_SRCS}
+ solv_zchunk.c)
+ENDIF (ENABLE_ZCHUNK_COMPRESSION)
+
SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC")
IF (HAVE_LINKER_VERSION_SCRIPT)
SET (CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} ${LINK_FLAGS} -Wl,--version-script=${CMAKE_SOURCE_DIR}/ext/libsolvext.ver")