summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@profusion.mobi>2012-01-26 19:26:35 -0200
committerLucas De Marchi <lucas.demarchi@profusion.mobi>2012-01-26 19:26:35 -0200
commit5ac9c07aac2e2d63a4c1855b34672c2ceb6ea7e8 (patch)
tree8147ef4f2f0eb4d1a03b0e925e8002ecc48cb472 /Makefile.am
parente701e381faac8977f472b881d426335b869998dc (diff)
downloadkmod-5ac9c07aac2e2d63a4c1855b34672c2ceb6ea7e8.tar.gz
kmod-5ac9c07aac2e2d63a4c1855b34672c2ceb6ea7e8.tar.bz2
kmod-5ac9c07aac2e2d63a4c1855b34672c2ceb6ea7e8.zip
build-sys: extract rootfs for make check
Commit "d2c2b8b build-sys: autotoolify build of check libraries" removed rootfs extraction. Add it back.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 22e882b..2dc09a3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -133,6 +133,10 @@ endif
# TESTSUITE
# ------------------------------------------------------------------------------
+testsuite/rootfs:
+ $(AM_V_GEN) tar -C testsuite/ \
+ -xJf $(top_srcdir)/testsuite/rootfs.tar.xz
+
TESTSUITE_OVERRIDE_LIBS = testsuite/uname.la testsuite/path.la \
testsuite/init_module.la \
testsuite/delete_module.la