summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schuh <andreas.schuh.84@gmail.com>2014-05-02 11:12:05 +0100
committerAndreas Schuh <andreas.schuh.84@gmail.com>2014-05-02 11:12:05 +0100
commitcd7aece14e2aac0669292c95ab42de6e267a5034 (patch)
treefd7c33562ec8002887b2f9662a2ece80d4664d16 /CMakeLists.txt
parentbf889786c2a3a2dab89610d0722634d2eedfc694 (diff)
downloadgflags-cd7aece14e2aac0669292c95ab42de6e267a5034.tar.gz
gflags-cd7aece14e2aac0669292c95ab42de6e267a5034.tar.bz2
gflags-cd7aece14e2aac0669292c95ab42de6e267a5034.zip
Use major version number only as SOVERSION.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7f65563..ca2c1df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,7 +22,7 @@ version_numbers (
PACKAGE_VERSION_PATCH
)
-set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}")
+set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}")
# ----------------------------------------------------------------------------
# options
@@ -258,10 +258,9 @@ foreach (TYPE IN ITEMS STATIC SHARED)
endif ()
set_target_properties (
gflags${opts}-${type} PROPERTIES COMPILE_DEFINITIONS "${defines}"
- OUTPUT_NAME "gflags${opts}"
- # Set VERSION instead of SOVERSION such
- # that it is also used on Windows
- VERSION "${PACKAGE_SOVERSION}"
+ OUTPUT_NAME "gflags${opts}"
+ VERSION "${PACKAGE_VERSION}"
+ SOVERSION "${PACKAGE_SOVERSION}"
)
if (HAVE_SHLWAPI_H)
target_link_libraries (gflags${opts}-${type} shlwapi.lib)