summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schuh <andreas.schuh.84@gmail.com>2014-05-01 20:16:16 +0100
committerAndreas Schuh <andreas.schuh.84@gmail.com>2014-05-01 20:16:16 +0100
commitbf889786c2a3a2dab89610d0722634d2eedfc694 (patch)
treefcef2b7ce2a9fd3de35dde85c48f2c69e9648106 /CMakeLists.txt
parente160474c52dd831fa5d60f97610bb73998dcddac (diff)
downloadgflags-bf889786c2a3a2dab89610d0722634d2eedfc694.tar.gz
gflags-bf889786c2a3a2dab89610d0722634d2eedfc694.tar.bz2
gflags-bf889786c2a3a2dab89610d0722634d2eedfc694.zip
Set VERSION property of library targets to <major>.<minor>.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4d0f07..7f65563 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,8 @@ version_numbers (
PACKAGE_VERSION_PATCH
)
+set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}.${PACKAGE_VERSION_MINOR}")
+
# ----------------------------------------------------------------------------
# options
set (GFLAGS_NAMESPACE "${PACKAGE_NAME}" CACHE STRING "C++ namespace identifier of gflags library.")
@@ -257,6 +259,9 @@ foreach (TYPE IN ITEMS STATIC SHARED)
set_target_properties (
gflags${opts}-${type} PROPERTIES COMPILE_DEFINITIONS "${defines}"
OUTPUT_NAME "gflags${opts}"
+ # Set VERSION instead of SOVERSION such
+ # that it is also used on Windows
+ VERSION "${PACKAGE_SOVERSION}"
)
if (HAVE_SHLWAPI_H)
target_link_libraries (gflags${opts}-${type} shlwapi.lib)