summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9657830..c3ebbad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,10 @@ MESSAGE("Build type: ${CMAKE_BUILD_TYPE}")
# Set required packages
INCLUDE(FindPkgConfig)
+IF (with_wayland)
+ ADD_DEFINITIONS("-DWAYLAND")
+ENDIF(with_wayland)
+
pkg_check_modules(libpkgs REQUIRED aul dlog bundle sqlite3 glib-2.0 dbus-glib-1)
FOREACH(flag ${libpkgs_CFLAGS})