summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLi,Limin <liminx.li@intel.com>2014-01-06 17:53:54 +0800
committerLi,Limin <liminx.li@intel.com>2014-01-06 18:04:12 +0800
commitd8b5f507cb937305d20ecc7fed769683279184d1 (patch)
tree8589681ce2de471ba92dbc52cb71607d46886bf0 /CMakeLists.txt
parent51f08c814a1c923837941064db762eebcb164bc1 (diff)
downloadsyspopup-d8b5f507cb937305d20ecc7fed769683279184d1.tar.gz
syspopup-d8b5f507cb937305d20ecc7fed769683279184d1.tar.bz2
syspopup-d8b5f507cb937305d20ecc7fed769683279184d1.zip
init wayland supportsubmit/tizen/20140110.215426
The display server based on X or Wayland, is now a choice of different profile in Tizen 3.0. Basically and consistently, two macros were used "with wayland" and "with x". Below summarize the combination of the macros: | wayland | x | meaning |--------------------------- | 0 | 1 | pure X11 platform(no wayland) | 1 | 0 | pure wayland platform (no X11) | 1 | 1 | wayland but X compatibility | 0 | 0 | no X and no wayland This method unifies the meaning and usage. Deploy this method to syspopup package. fix the bug:https://bugs.tizen.org/jira/browse/PTREL-531 Signed-off-by: Li,Limin <liminx.li@intel.com> Change-Id: Id3f61e652e22115d47c7ef8d50dd5cb70b64c112
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9657830..c3ebbad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,10 @@ MESSAGE("Build type: ${CMAKE_BUILD_TYPE}")
# Set required packages
INCLUDE(FindPkgConfig)
+IF (with_wayland)
+ ADD_DEFINITIONS("-DWAYLAND")
+ENDIF(with_wayland)
+
pkg_check_modules(libpkgs REQUIRED aul dlog bundle sqlite3 glib-2.0 dbus-glib-1)
FOREACH(flag ${libpkgs_CFLAGS})