summaryrefslogtreecommitdiff
path: root/set_pmon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'set_pmon/CMakeLists.txt')
-rw-r--r--set_pmon/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/set_pmon/CMakeLists.txt b/set_pmon/CMakeLists.txt
new file mode 100644
index 0000000..72f3c70
--- /dev/null
+++ b/set_pmon/CMakeLists.txt
@@ -0,0 +1,13 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+set(SET_PMON set_pmon)
+
+SET(SRCS set_pmon.c)
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
+
+ADD_EXECUTABLE(${SET_PMON} ${SRCS})
+TARGET_LINK_LIBRARIES(${SET_PMON} ${PROJECT_NAME})
+INSTALL(TARGETS ${SET_PMON} DESTINATION bin)
+INSTALL(PROGRAMS ${CMAKE_BINARY_DIR}/set_pmon/regpmon.sh DESTINATION bin)
+
+# install rc script
+INSTALL(PROGRAMS ${CMAKE_BINARY_DIR}/set_pmon/pmon DESTINATION /etc/rc.d/init.d)