summaryrefslogtreecommitdiff
path: root/set_pmon/CMakeLists.txt
diff options
context:
space:
mode:
authorHyungKyu Song <hk76.song@samsung.com>2013-02-16 00:16:25 +0900
committerHyungKyu Song <hk76.song@samsung.com>2013-02-16 00:16:25 +0900
commitffc1b2e81b03a2ddc03edafef7abffc1be4454c0 (patch)
tree1c1a876954a650cfef753a9bb019e132ae9cc8bc /set_pmon/CMakeLists.txt
parent53096f6974850e1ac26414ff4bbfe5d632ab0c07 (diff)
downloadlibslp-sysman-tizen_2.0.tar.gz
libslp-sysman-tizen_2.0.tar.bz2
libslp-sysman-tizen_2.0.zip
Diffstat (limited to 'set_pmon/CMakeLists.txt')
-rw-r--r--set_pmon/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/set_pmon/CMakeLists.txt b/set_pmon/CMakeLists.txt
new file mode 100644
index 0000000..72f3c70
--- /dev/null
+++ b/set_pmon/CMakeLists.txt
@@ -0,0 +1,13 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+set(SET_PMON set_pmon)
+
+SET(SRCS set_pmon.c)
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
+
+ADD_EXECUTABLE(${SET_PMON} ${SRCS})
+TARGET_LINK_LIBRARIES(${SET_PMON} ${PROJECT_NAME})
+INSTALL(TARGETS ${SET_PMON} DESTINATION bin)
+INSTALL(PROGRAMS ${CMAKE_BINARY_DIR}/set_pmon/regpmon.sh DESTINATION bin)
+
+# install rc script
+INSTALL(PROGRAMS ${CMAKE_BINARY_DIR}/set_pmon/pmon DESTINATION /etc/rc.d/init.d)