summaryrefslogtreecommitdiff
path: root/lua/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lua/Makefile.am')
-rw-r--r--lua/Makefile.am77
1 files changed, 77 insertions, 0 deletions
diff --git a/lua/Makefile.am b/lua/Makefile.am
new file mode 100644
index 000000000..c33d8d1ed
--- /dev/null
+++ b/lua/Makefile.am
@@ -0,0 +1,77 @@
+
+noinst_LTLIBRARIES = liblua.la
+noinst_PROGRAMS = lua/lua luac/luac
+
+EXTRA_DIST = COPYRIGHT HISTORY
+
+LDADD = liblua.la
+INCLUDES = -I$(srcdir)/include -I$(srcdir)/local
+
+lua_lua_SOURCES = lua/lua.c
+lua_lua_CFLAGS = -DLUA_USERCONFIG='"$(srcdir)/local/userconfig.c"'
+lua_lua_LDADD = $(LDADD) -lreadline -lhistory -lncurses
+luac_luac_SOURCES = luac/luac.c luac/print.c lopcodes.c
+luac_luac_CFLAGS = -DLUA_OPNAMES
+
+liblua_la_CFLAGS = -DUSE_DLOPEN -DWITH_POSIX
+liblua_la_LIBADD = -lm -ldl
+liblua_la_SOURCES = \
+ local/linit.c \
+ local/linit.lch \
+ local/lposix.h \
+ local/lposix.c \
+ local/lrexlib.h \
+ local/lrexlib.c \
+ include/lauxlib.h \
+ include/lua.h \
+ include/lualib.h \
+ lib/lauxlib.c \
+ lib/lbaselib.c \
+ lib/ldblib.c \
+ lib/liolib.c \
+ lib/lmathlib.c \
+ lib/loadlib.c \
+ lib/lstrlib.c \
+ lib/ltablib.c \
+ lapi.c \
+ lapi.h \
+ lcode.c \
+ lcode.h \
+ ldebug.c \
+ ldebug.h \
+ ldo.c \
+ ldo.h \
+ ldump.c \
+ lfunc.c \
+ lfunc.h \
+ lgc.c \
+ lgc.h \
+ llex.c \
+ llex.h \
+ llimits.h \
+ lmem.c \
+ lmem.h \
+ lobject.c \
+ lobject.h \
+ lopcodes.c \
+ lopcodes.h \
+ lparser.c \
+ lparser.h \
+ lstate.c \
+ lstate.h \
+ lstring.c \
+ lstring.h \
+ ltable.c \
+ ltable.h \
+ ltests.c \
+ ltm.c \
+ ltm.h \
+ lundump.c \
+ lundump.h \
+ lvm.c \
+ lvm.h \
+ lzio.c \
+ lzio.h
+
+local/linit.lch: local/linit.lua
+ bin2c local/linit.lua > local/linit.lch