summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control8
-rw-r--r--debian/librpm-tizen.install4
-rwxr-xr-xdebian/rules6
3 files changed, 8 insertions, 10 deletions
diff --git a/debian/control b/debian/control
index a3a31bc4c..5aac23660 100644
--- a/debian/control
+++ b/debian/control
@@ -2,6 +2,7 @@ Source: librpm-tizen
Section: vcs
Priority: optional
Build-Depends: debhelper,
+ dh-python,
dpkg-dev,
dh-autoreconf,
libtool,
@@ -14,7 +15,8 @@ Build-Depends: debhelper,
libxml2-dev,
libreadline-dev,
libsqlite3-dev,
- python-all-dev,
+ python3-all-dev,
+ python3,
pkg-config,
libnspr4-dev,
libnss3-dev,
@@ -27,11 +29,11 @@ Build-Depends: debhelper,
Maintainer: Markus Lehtonen <markus.lehtonen@linux.intel.com>
Standards-Version: 3.9.3
Homepage: http://rpm.org/
-X-Python-Version: >= 2.6
+X-Python-Version: >= 3
Package: librpm-tizen
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, ${python:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}, ${python3:Depends}
Description: The RPM libraries for git-buildpackage
RPM Package Manager is the main tool for managing the software packages
of Tizen.
diff --git a/debian/librpm-tizen.install b/debian/librpm-tizen.install
index 78f09f7b8..84594ba09 100644
--- a/debian/librpm-tizen.install
+++ b/debian/librpm-tizen.install
@@ -1,4 +1,4 @@
usr/lib*/*/*.so.*
usr/lib*/*/rpm/*
-usr/lib/python*/dist-packages/*/*.so
-usr/lib/python*/dist-packages/*/*.py*
+usr/lib/python*/*packages/*/*.so
+usr/lib/python*/*packages/*/*.py*
diff --git a/debian/rules b/debian/rules
index 594963018..c396cb479 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,8 +5,7 @@ python_mod_name := rpm_tizen
CPPFLAGS += $(shell pkg-config --cflags nss)
%:
- dh $@ --with python2,autoreconf,autotools_dev
-
+ dh $@ --with python3,autoreconf,autotools_dev
override_dh_auto_configure:
dh_auto_configure -- --disable-dependency-tracking \
--libdir=/usr/lib/librpm-tizen \
@@ -28,6 +27,3 @@ override_dh_auto_install:
install -d debian/tmp/usr/lib/librpm-tizen/rpm/tizen
ln -s ../tizen_macros debian/tmp/usr/lib/librpm-tizen/rpm/tizen/macros
-override_dh_python2:
- dh_python2 --no-guessing-versions
-