summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsépius <corsepiu@fedoraproject.org>2007-08-23 16:38:12 +0200
committerRalf Corsépius <corsepiu@fedoraproject.org>2007-08-23 16:38:12 +0200
commit87de0b28f58b2e8adcd1ca468c809c35dfc54e6e (patch)
tree2c3f8948efacf73a37a8c942c8cf3f3149e39891 /tests/Makefile.am
parente0f6bee0852c8433aa0fe39a1c760e94a98f6177 (diff)
downloadlibrpm-tizen-87de0b28f58b2e8adcd1ca468c809c35dfc54e6e.tar.gz
librpm-tizen-87de0b28f58b2e8adcd1ca468c809c35dfc54e6e.tar.bz2
librpm-tizen-87de0b28f58b2e8adcd1ca468c809c35dfc54e6e.zip
Create a customized rpmpopt-$(VERSION).
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ede849f2e..4a92067dc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -76,14 +76,24 @@ macros.in: $(top_srcdir)/macros.in
CLEANFILES += macros.in
+## Create a customized rpmpopt
+rpmpopt.in: $(top_srcdir)/rpmpopt.in
+ @sed \
+ -e "s,[@]RPMCONFIGDIR[@],`pwd`/testing$(RPMCONFIGDIR),g" \
+ < $(top_srcdir)/rpmpopt.in > rpmpopt.in
+CLEANFILES += rpmpopt.in
+
+
## Create a test-installation directory "testing"
-testing@RPMCONFIGDIR@/rpmrc: rpmrc.in macros.in $(top_builddir)/config.status
+testing@RPMCONFIGDIR@/rpmrc: rpmrc.in macros.in rpmpopt.in $(top_builddir)/config.status
(cd ${top_builddir} && \
$(MAKE) DESTDIR=`pwd`/${subdir}/testing install)
(cd ${top_builddir} && \
./config.status --file=${subdir}/testing$(RPMCONFIGDIR)/rpmrc:${subdir}/rpmrc.in)
(cd ${top_builddir} && \
./config.status --file=${subdir}/testing$(RPMCONFIGDIR)/macros:${subdir}/macros.in)
+ (cd ${top_builddir} && \
+ ./config.status --file=${subdir}/testing$(RPMCONFIGDIR)/rpmpopt-@VERSION@:${subdir}/rpmpopt.in)
check_DATA = testing@RPMCONFIGDIR@/rpmrc atconfig atlocal $(TESTSUITE)