summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorjbj <devnull@localhost>2001-05-11 04:01:04 +0000
committerjbj <devnull@localhost>2001-05-11 04:01:04 +0000
commitc7ee57336766b4411f3aeaaa78dd3778cfea3244 (patch)
tree628669756123446e12df3962c0d77db02551521f /lib/Makefile.am
parentdda243d6621372bf8c10bc04643e730d9e388091 (diff)
downloadlibrpm-tizen-c7ee57336766b4411f3aeaaa78dd3778cfea3244.tar.gz
librpm-tizen-c7ee57336766b4411f3aeaaa78dd3778cfea3244.tar.bz2
librpm-tizen-c7ee57336766b4411f3aeaaa78dd3778cfea3244.zip
- rpm database has rpm.rpm g+w permissions to share db3 mutexes.
- expose more db3 macro configuration tokens. - move fprint.[ch] and hash.[ch] to rpmdb directory. - detect and fiddle incompatible mixtures of db3 env/open flags. - add DBI_WRITECURSOR to map to db3 flags with CDB database model. - add rpmdbSetIteratorRewrite to warn of pending lazy (re-)writes. CVS patchset: 4765 CVS date: 2001/05/11 04:01:04
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index a1b4974e0..7a112e608 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -16,7 +16,7 @@ pkgincdir = $(pkgincludedir)
pkginc_HEADERS = \
header.h misc.h rpmlib.h stringbuf.h
noinst_HEADERS = \
- cpio.h depends.h fprint.h fsm.h hash.h \
+ cpio.h depends.h fsm.h \
manifest.h md5.h psm.h \
rpmlead.h signature.h
@@ -31,8 +31,8 @@ LIBS =
lib_LTLIBRARIES = librpm.la
librpm_la_SOURCES = \
- cpio.c depends.c formats.c fprint.c fs.c fsm.c getdate.c \
- hash.c header.c manifest.c md5.c md5sum.c misc.c package.c \
+ cpio.c depends.c formats.c fs.c fsm.c getdate.c \
+ header.c manifest.c md5.c md5sum.c misc.c package.c \
problems.c poptBT.c poptQV.c psm.c query.c rpmchecksig.c \
rpminstall.c rpmlead.c rpmlibprov.c rpmrc.c signature.c \
stringbuf.c tagName.c tagtable.c transaction.c verify.c