summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorjbj <devnull@localhost>2002-12-14 21:39:19 +0000
committerjbj <devnull@localhost>2002-12-14 21:39:19 +0000
commit96f4a259b507751db2d51b43978ba7b69a149c3a (patch)
treebce4ffcb4f7a645cbfa91f190fdbd2502b3fcf05 /lib/Makefile.am
parent23a39efab69f2b60624a7c112ba7eb1a939afff1 (diff)
downloadlibrpm-tizen-96f4a259b507751db2d51b43978ba7b69a149c3a.tar.gz
librpm-tizen-96f4a259b507751db2d51b43978ba7b69a149c3a.tar.bz2
librpm-tizen-96f4a259b507751db2d51b43978ba7b69a149c3a.zip
- fix: make sure each library has DT_NEEDED for all unresolved syms.
CVS patchset: 5941 CVS date: 2002/12/14 21:39:19
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am30
1 files changed, 11 insertions, 19 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 35260b03f..e3385f6bf 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -21,13 +21,7 @@ pkginc_HEADERS = \
noinst_HEADERS = \
cpio.h fsm.h manifest.h psm.h rpmlead.h signature.h
-mylibpaths = \
- -L$(top_builddir)/lib \
- -L$(top_builddir)/rpmdb \
- -L$(top_builddir)/rpmio \
- -L$(top_builddir)/popt
-
-mylibs = -lrpm -lrpmdb -lrpmio -lpopt @WITH_LIBELF_LIB@ @LIBS@ @INTLLIBS@ @LIBMISC@
+mylibs = librpm.la
LIBS =
usrlibdir = $(libdir)@MARK64@
@@ -40,13 +34,10 @@ librpm_la_SOURCES = \
rpmlead.c rpmlibprov.c rpmps.c rpmrc.c rpmte.c rpmts.c rpmvercmp.c \
signature.c stringbuf.c transaction.c \
verify.c
-librpm_la_LDFLAGS = -release @VERSION@ $(top_builddir)/rpmdb/librpmdb.la
-
-# XXX Add internal libtool dependence
-install-data-local: install-usrlibLTLIBRARIES
- @cd $(DESTDIR)/$(usrlibdir) && \
- sed -e "s|^dependency_libs='|& -lrpmdb-@VERSION@ -lrpmio-@VERSION@ -lpopt|" < librpm.la > .librpm.la && \
- mv .librpm.la librpm.la
+librpm_la_LDFLAGS = -release @VERSION@ \
+ $(top_builddir)/rpmdb/librpmdb.la \
+ $(top_builddir)/rpmio/librpmio.la \
+ $(top_builddir)/popt/libpopt.la
getdate.c: getdate.y
@echo expect 10 shift/reduce conflicts
@@ -95,16 +86,17 @@ lint:
$(LINT) $(DEFS) $(INCLUDES) $(librpm_la_SOURCES)
th: th.c librpm.la
- $(CC) $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< $(mylibpaths) $(mylibs) $(LIBS)
+ $(CC) $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< $(mylibs)
#tds: tds.c librpm.la
-# $(CC) $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< librpm.la
+# $(CC) $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< $(mylibs)
#
+
trb: trb.o librpm.la
- $(LINK) @LDFLAGS_STATIC@ $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ trb.o $(mylibs) $(LIBS)
+ $(LINK) @LDFLAGS_STATIC@ $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< $(mylibs)
tplatform: tplatform.o librpm.la
- $(LINK) @LDFLAGS_STATIC@ $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ tplatform.o $(mylibpaths) $(mylibs) $(LIBS)
+ $(LINK) @LDFLAGS_STATIC@ $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< $(mylibs)
trhn: trhn.o librpm.la
- $(LINK) @LDFLAGS_STATIC@ $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ trhn.o $(mylibs) $(LIBS)
+ $(LINK) @LDFLAGS_STATIC@ $(CFLAGS) $(DEFS) $(INCLUDES) -o $@ $< $(mylibs)