summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2009-12-23 12:25:32 +0200
committerPanu Matilainen <pmatilai@redhat.com>2009-12-23 12:25:32 +0200
commit5c31864598a169bbf0609635f162bc089ea3ccda (patch)
tree9d838225f9ab306d6f087af793d7a174c49dd3f7 /configure.ac
parent0de16638aadfc7fc093e69106e7f3a6b54a2ff28 (diff)
downloadlibrpm-tizen-5c31864598a169bbf0609635f162bc089ea3ccda.tar.gz
librpm-tizen-5c31864598a169bbf0609635f162bc089ea3ccda.tar.bz2
librpm-tizen-5c31864598a169bbf0609635f162bc089ea3ccda.zip
Dont bother checking for functions we dont use
- some of this stuff was used in 4.4.x but not anymore - additionally we dont even use getdomainnname(), check for gethostname() instead
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 2 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index a33a9c51f..87a5b9d96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,23 +210,11 @@ dnl
dnl Checks for libraries.
-AC_CHECK_FUNC(setreuid, [], [
- AC_CHECK_LIB(ucb, setreuid, [if echo $LIBS | grep -- -lucb >/dev/null ;then :; else LIBS="$LIBS -lc -lucb" USEUCB=y;fi])
-])
-
-AC_CHECK_FUNC(rand, [], [
- AC_CHECK_LIB(rand, rand, [])
-])
-
-AC_CHECK_FUNC(getdomainname, [], [
- AC_CHECK_LIB(nsl, getdomainname)
-])
-AC_CHECK_FUNC(socket, [], [
- AC_CHECK_LIB(socket, socket)
+AC_CHECK_FUNC(gethostname, [], [
+ AC_CHECK_LIB(nsl, gethostname)
])
AC_CHECK_HEADERS(error.h)
-AC_CHECK_FUNCS(error)
AC_CHECK_HEADERS(poll.h)
@@ -565,7 +553,6 @@ dnl point, but should offer good performance improvements, check after
dnl 4.4.2.1...
dnl AC_FUNC_MMAP
-AC_CHECK_FUNCS(getaddrinfo getnameinfo inet_aton)
AC_CHECK_FUNCS(mtrace)
AC_CHECK_FUNCS(strndup strerror)