summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2011-03-25 11:25:47 +0200
committerPanu Matilainen <pmatilai@redhat.com>2011-03-25 11:25:47 +0200
commit2b6486a69b54a5d2a3c56ec9489f25f5c7125b3c (patch)
tree7ff21354335988b190f143047909a673159df0ca /configure.ac
parenta0d04112c014969e2bdf5f7f280e6635ceea40e8 (diff)
downloadlibrpm-tizen-2b6486a69b54a5d2a3c56ec9489f25f5c7125b3c.tar.gz
librpm-tizen-2b6486a69b54a5d2a3c56ec9489f25f5c7125b3c.tar.bz2
librpm-tizen-2b6486a69b54a5d2a3c56ec9489f25f5c7125b3c.zip
Replace distro/vendor autodetection with a configure switch
- it's not rpm's job, not is it possible for rpm to know about distribution/vendor names and preferences - use build_vendor as the canonical vendor (affecting %{_vendor} default and macro + rpmrc paths) unless overridden by --with-vendor=name
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 7 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index e71364c8f..4d2147a28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -802,19 +802,14 @@ esac
case "${host_os_noversion}" in
mint) RPMCANONARCH=m68kmint ;;
esac
+
+dnl permit overriding build_vendor for "canonical rpm vendor"
RPMCANONVENDOR="$build_vendor"
-case "${build_vendor}" in
-unknown|pc|ibm|redhat|pld|mandrake|conectiva|lvr|yellowdog|caos|suse)
- test -f /etc/redhat-release && RPMCANONVENDOR=redhat
- test -f /etc/SuSE-release && RPMCANONVENDOR=suse
- test -f /etc/pld-release && RPMCANONVENDOR=pld
- test -f /etc/mandrake-release && RPMCANONVENDOR=mandrake
- test -f /etc/conectiva-release && RPMCANONVENDOR=conectiva
- test -f /etc/lvr-release && RPMCANONVENDOR=lvr
- test -f /etc/yellowdog-release && RPMCANONVENDOR=yellowdog
- test -f /etc/caos-release && RPMCANONVENDOR=caos
- ;;
-esac
+AC_ARG_WITH([vendor],
+ AS_HELP_STRING([--with-vendor=VENDOR], [specify rpm vendor name]),
+ [RPMCANONVENDOR=$withval])
+AC_DEFINE_UNQUOTED([RPMCANONVENDOR],["${RPMCANONVENDOR}"],[canonical vendor])
+
RPMCANONOS="$host_os_noversion"
RPMCANONGNU="$host_os_gnu"
AC_SUBST(RPMCANONCOLOR)
@@ -822,7 +817,6 @@ AC_SUBST(RPMCANONARCH)
AC_SUBST(RPMCANONVENDOR)
AC_SUBST(RPMCANONOS)
AC_SUBST(RPMCANONGNU)
-AC_DEFINE_UNQUOTED([RPMCANONVENDOR],["${RPMCANONVENDOR}"],[canonical vendor])
if test X"$prefix" = XNONE ; then
usrprefix="$ac_default_prefix"