summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2008-04-16 15:13:25 +0300
committerPanu Matilainen <pmatilai@redhat.com>2008-04-16 15:37:52 +0300
commitd48e6c8380ebd1f8d4d4f2c80237dc1488da4721 (patch)
tree004158090fc80b15a620f2c960b0e029cad25835 /Makefile.am
parent23f6917b10b6579f39199e4cf831bb13fc596824 (diff)
downloadlibrpm-tizen-d48e6c8380ebd1f8d4d4f2c80237dc1488da4721.tar.gz
librpm-tizen-d48e6c8380ebd1f8d4d4f2c80237dc1488da4721.tar.bz2
librpm-tizen-d48e6c8380ebd1f8d4d4f2c80237dc1488da4721.zip
Start phasing out internal copy of Lua
- don't build internal copy of Lua - move 3rd party extensions (posix and rexlib) to toplevel luaext/ directory, built by default (unless --without-lua specified) - auto*foo checks for external Lua - minimal tweaks to lposix.c and rpmlua.c to get them build with Lua 5.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e98eed03..361c7959d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,9 +16,12 @@ SUBDIRS = po misc
if WITH_INTERNAL_DB
SUBDIRS += db3
endif
-SUBDIRS += lua rpmio rpmdb lib build python scripts doc . tests
+if WITH_LUAEXT
+SUBDIRS += luaext
+endif
+SUBDIRS += rpmio rpmdb lib build python scripts doc . tests
-DIST_SUBDIRS = po misc lua rpmio rpmdb lib build python scripts doc tests
+DIST_SUBDIRS = po misc luaext rpmio rpmdb lib build python scripts doc tests
pkgconfigdir = $(libdir)/pkgconfig