summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2014-10-17 18:24:01 +0200
committerJun Wang <junbill.wang@samsung.com>2016-01-27 00:45:38 +0800
commit40115b1d10c166ddddeaee68fd4f35901a4971d8 (patch)
treedbe7a31ebd1c9911e765353d98128ccb0ca59bf3 /setup.py
parent45707a09054c3b2678b57a41c91d3f8fdb13a157 (diff)
downloadgit-buildpackage-40115b1d10c166ddddeaee68fd4f35901a4971d8.tar.gz
git-buildpackage-40115b1d10c166ddddeaee68fd4f35901a4971d8.tar.bz2
git-buildpackage-40115b1d10c166ddddeaee68fd4f35901a4971d8.zip
Complete setup.py for pypi
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 15 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e1159888..e733f9d7 100644
--- a/setup.py
+++ b/setup.py
@@ -42,10 +42,25 @@ def fetch_version():
return version
+
+def readme():
+ with open('README') as file:
+ return file.read()
+
setup(name = "gbp",
version = fetch_version(),
author = u'Guido Günther',
author_email = 'agx@sigxcpu.org',
+ url = 'https://honk.sigxcpu.org/piki/projects/git-buildpackage/',
+ description = 'Suite to help with Debian packages in Git repositories',
+ license = 'GPLv2+',
+ long_description = readme(),
+ classifiers = [
+ 'Environment :: Console',
+ 'Programming Language :: Python :: 2',
+ 'Topic :: Software Development :: Version Control :: Git',
+ 'Operating System :: POSIX :: Linux',
+ ],
scripts = [ 'bin/git-buildpackage',
'bin/git-import-dsc',
'bin/git-import-orig',