summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorbiao716.wang <biao716.wang@samsung.com>2022-11-25 22:24:26 +0900
committerbiao716.wang <biao716.wang@samsung.com>2022-11-28 21:21:23 +0900
commit6f7ef991f742eb5c5226272ca28edd71a2424143 (patch)
tree8dc1dda13dca3149b20cfdf77ed97e1732e56fe9 /debian
parent0ddd0409b7ba0e9cb3e5234a506041ff032c2e27 (diff)
downloadgit-buildpackage-6f7ef991f742eb5c5226272ca28edd71a2424143.tar.gz
git-buildpackage-6f7ef991f742eb5c5226272ca28edd71a2424143.tar.bz2
git-buildpackage-6f7ef991f742eb5c5226272ca28edd71a2424143.zip
porting code to python3.x with os patch
Change-Id: I3deda71d6bde7c3363800d79d2e9ae6998bdb9e7 Signed-off-by: biao716.wang <biao716.wang@samsung.com>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/control6
-rwxr-xr-xdebian/rules3
2 files changed, 5 insertions, 4 deletions
diff --git a/debian/control b/debian/control
index afd3198c..0ccbc204 100755
--- a/debian/control
+++ b/debian/control
@@ -24,7 +24,7 @@ Standards-Version: 3.9.4
Vcs-Git: git://honk.sigxcpu.org/git/git-buildpackage.git
Vcs-Browser: https://honk.sigxcpu.org/gitweb/?p=git-buildpackage.git
Homepage: https://honk.sigxcpu.org/piki/projects/git-buildpackage/
-X-Python-Version: >= 2.6
+X-Python3-Version: >= 3.5
Package: git-buildpackage-common
@@ -32,14 +32,16 @@ Architecture: all
Depends: ${python3:Depends},
${shlibs:Depends},
${misc:Depends},
+ devscripts (>= 2.13.5~),
git (>= 1:1.7.9.1-1~),
man-db,
+ python3-dateutil,
python3-pkg-resources,
python3-dateutil,
#unittest need
zipmerge
Recommends: pristine-tar (>= 0.5)
-Suggests: python-notify, unzip, zipmerge
+Suggests: python3-notify2, unzip, zipmerge
Description: Suite to help with packaging in Git repositories
This package contains the common API and scripts for Debian and rpm packaging
diff --git a/debian/rules b/debian/rules
index 91265d43..0ac72e48 100755
--- a/debian/rules
+++ b/debian/rules
@@ -37,8 +37,7 @@ endif
override_dh_auto_build:
dh_auto_build
make -C docs
- #generate apidocs
- #sh gen_apidocs.sh
+
override_dh_auto_install:
dh_auto_install
dh_bash-completion