summaryrefslogtreecommitdiff
path: root/packaging/sqlite.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/sqlite.spec')
-rwxr-xr-xpackaging/sqlite.spec66
1 files changed, 66 insertions, 0 deletions
diff --git a/packaging/sqlite.spec b/packaging/sqlite.spec
new file mode 100755
index 0000000..a7d648b
--- /dev/null
+++ b/packaging/sqlite.spec
@@ -0,0 +1,66 @@
+Name: sqlite
+Summary: Library that implements an embeddable SQL database engine
+Version: 3.7.13
+Release: 0
+Group: Applications/Databases
+License: Public Domain
+URL: http://www.sqlite.org/download.html
+#%define tar_ver 3071300
+#Source: http://www.sqlite.org/sqlite-autoconf-%{tar_ver}.tar.gz
+Source: %{name}-%{version}.tar.gz
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+
+%description
+SQLite is a C library that implements an SQL database engine. A large
+subset of SQL92 is supported. A complete database is stored in a
+single disk file. The API is designed for convenience and ease of use.
+Applications that link against SQLite can enjoy the power and
+flexibility of an SQL database without the administrative hassles of
+supporting a separate database server. Version 2 and version 3 binaries
+are named to permit each to be installed on a single host
+
+%package devel
+Summary: Development tools for the sqlite3 embeddable SQL database engine
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
+
+%description devel
+This package contains the header files and development documentation
+for %{name}. If you like to develop programs using %{name}, you will need
+to install %{name}-devel.
+
+%prep
+%setup -q -n %{name}-%{version}
+
+#%patch0 -p1
+
+%build
+
+%reconfigure --prefix=%{_prefix} \
+ CFLAGS="$RPM_OPT_FLAGS " \
+ --enable-shared=yes \
+ --enable-static=no \
+ --enable-threadsafe
+
+make %{?jobs:-j%jobs}
+
+%install
+rm -rf %{buildroot}
+
+%make_install
+rm -rf $RPM_BUILD_ROOT/usr/share/man
+
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%files
+%manifest sqlite3.manifest
+%{_bindir}/*
+%{_libdir}/*.so.*
+
+%files devel
+%{_includedir}/*.h
+%{_libdir}/*.so
+%{_libdir}/pkgconfig/*.pc