summaryrefslogtreecommitdiff
path: root/luaext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'luaext/Makefile.am')
-rw-r--r--luaext/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/luaext/Makefile.am b/luaext/Makefile.am
new file mode 100644
index 0000000..65e1555
--- /dev/null
+++ b/luaext/Makefile.am
@@ -0,0 +1,19 @@
+noinst_LTLIBRARIES = libluaext.la
+
+EXTRA_DIST = \
+ modemuncher.c \
+ userconfig.c \
+ linit.lua
+
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_builddir)/include -I.
+
+libluaext_la_CPPFLAGS = $(AM_CPPFLAGS) -DWITH_POSIX @LUA_CFLAGS@
+libluaext_la_LIBADD = @LUA_LIBS@
+libluaext_la_SOURCES = \
+ lposix.h \
+ lposix.c \
+ lrexlib.h \
+ lrexlib.c
+
+linit.lch: linit.lua
+ bin2c linit.lua > linit.lch