summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJunfeng Dong <junfeng.dong@intel.com>2012-06-05 17:27:50 +0800
committerJunfeng Dong <junfeng.dong@intel.com>2012-06-05 17:27:50 +0800
commitb5e47a5b56f360f78f0e086ca4af3159dcb28e27 (patch)
tree7df6f7ef0ec82bdabd93c5bee5f1e2e78ba36582 /Makefile.am
parent94865d2997df82fb40f0092682e090614dd98b7f (diff)
downloaddiffutils-b5e47a5b56f360f78f0e086ca4af3159dcb28e27.tar.gz
diffutils-b5e47a5b56f360f78f0e086ca4af3159dcb28e27.tar.bz2
diffutils-b5e47a5b56f360f78f0e086ca4af3159dcb28e27.zip
Upload missing source files.HEAD2.0_alphamaster2.0alpha1.0_post
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..9d86cb1
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,43 @@
+# Main Automakefile for GNU diffutils.
+
+# Copyright (C) 2001-2002, 2004, 2006, 2009-2010 Free Software Foundation, Inc.
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+ALL_RECURSIVE_TARGETS =
+
+EXTRA_DIST = bootstrap exgettext ChangeLog-2008 cfg.mk dist-check.mk
+SUBDIRS = lib src tests doc man po ms gnulib-tests
+
+ACLOCAL_AMFLAGS = -I m4
+AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
+
+# Arrange so that .tarball-version appears only in the distribution
+# tarball, and never in a checked-out repository.
+dist-hook: gen-ChangeLog
+ $(AM_V_GEN)echo $(VERSION) > $(distdir)/.tarball-version
+
+gen_start_date = '2009-11-11 15:00'
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ --since=$(gen_start_date) > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
+ALL_RECURSIVE_TARGETS += distcheck-hook
+distcheck-hook:
+ $(MAKE) my-distcheck