summaryrefslogtreecommitdiff
path: root/Utilities/Doxygen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Utilities/Doxygen/CMakeLists.txt')
-rw-r--r--Utilities/Doxygen/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/Utilities/Doxygen/CMakeLists.txt b/Utilities/Doxygen/CMakeLists.txt
new file mode 100644
index 0000000..5d076e0
--- /dev/null
+++ b/Utilities/Doxygen/CMakeLists.txt
@@ -0,0 +1,41 @@
+#=============================================================================
+# CMake - Cross Platform Makefile Generator
+# Copyright 2000-2009 Kitware, Inc., Insight Software Consortium
+#
+# Distributed under the OSI-approved BSD License (the "License");
+# see accompanying file Copyright.txt for details.
+#
+# This software is distributed WITHOUT ANY WARRANTY; without even the
+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+# See the License for more information.
+#=============================================================================
+
+#
+# Build the documentation
+#
+INCLUDE (${CMAKE_ROOT}/Modules/Documentation.cmake OPTIONAL)
+
+IF (BUILD_DOCUMENTATION)
+
+ INCLUDE (${CMAKE_ROOT}/Modules/FindVTK.cmake)
+
+ #
+ # Configure the script and the doxyfile, then add target
+ #
+ IF(NOT DOT_PATH)
+ GET_FILENAME_COMPONENT(DOT_PATH ${DOT} PATH)
+ ENDIF(NOT DOT_PATH)
+
+ CONFIGURE_FILE(
+ ${CMake_SOURCE_DIR}/Utilities/Doxygen/doxyfile.in
+ ${CMake_BINARY_DIR}/Utilities/Doxygen/doxyfile)
+
+ CONFIGURE_FILE(
+ ${CMake_SOURCE_DIR}/Utilities/Doxygen/doc_makeall.sh.in
+ ${CMake_BINARY_DIR}/Utilities/Doxygen/doc_makeall.sh)
+
+ ADD_CUSTOM_TARGET(DoxygenDoc
+ ${BASH}
+ ${CMake_BINARY_DIR}/Utilities/Doxygen/doc_makeall.sh)
+
+ENDIF (BUILD_DOCUMENTATION)