summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules120
1 files changed, 120 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b2dba93
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,120 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+CFLAGS ?= -Wall -g
+LDFLAGS ?=
+PREFIX ?= /usr
+DESTDIR=$(CURDIR)/debian/tmp$(PREFIX)
+DATADIR ?= /opt
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+#LDFLAGS += -Wl,--rpath=$(PREFIX)/lib -Wl,--as-needed
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ #touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ $(MAKE) clean
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp.
+ mkdir -p $(CURDIR)/debian/tmp
+ mkdir -p $(CURDIR)/debian/tmp/usr/include
+ mkdir -p $(CURDIR)/debian/tmp/usr/lib
+ mkdir -p $(DESTDIR)/bin
+ mkdir -p $(DESTDIR)/include
+ mkdir -p $(DESTDIR)/lib
+ mkdir -p $(DESTDIR)/lib/pkgconfig
+
+ # simulator-opengl
+ cp -aRl lib/* $(DESTDIR)/lib/.
+
+ # simulator-opengl-dev
+ cp -a include/EGL $(DESTDIR)/include/.
+ cp -a include/GL $(DESTDIR)/include/.
+ cp -a include/GLES $(DESTDIR)/include/.
+ cp -a include/GLES2 $(DESTDIR)/include/.
+ cp -a include/KHR $(DESTDIR)/include/.
+
+
+# cp -afRl lib/* $(CURDIR)/debian/tmp/usr/lib/.
+ #cp -afRl include/* $(CURDIR)/debian/tmp/usr/include/.
+# cp -a include/EGL $(DESTDIR)/include/.
+# cp -a include/GLES $(DESTDIR)/include/.
+# cp -a include/GLES2 $(DESTDIR)/include/.
+# cp -a include/GL $(DESTDIR)/include/.
+
+ #cp -fRl lib/* $(CURDIR)/debian/tmp/usr/lib
+ #cp -fRl include/* $(CURDIR)/debian/tmp/usr/include
+ #$(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure