summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKim Kibum <kb0929.kim@samsung.com>2012-06-08 14:53:58 +0900
committerKim Kibum <kb0929.kim@samsung.com>2012-06-08 14:53:58 +0900
commit1cfb7d9b5e1e79b51848aaa6ab0d0bb7adb8ecdf (patch)
tree459261d15481727dfce32c4a395de050ccbb2192 /debian
parentadadfec02dc51f10959e8b88f4650fe5ee607270 (diff)
downloadcrash-worker-sdk-1cfb7d9b5e1e79b51848aaa6ab0d0bb7adb8ecdf.tar.gz
crash-worker-sdk-1cfb7d9b5e1e79b51848aaa6ab0d0bb7adb8ecdf.tar.bz2
crash-worker-sdk-1cfb7d9b5e1e79b51848aaa6ab0d0bb7adb8ecdf.zip
apply FSL(Flora Software License)
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/compat1
-rw-r--r--debian/control12
-rw-r--r--debian/copyright6
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs1
-rw-r--r--debian/org.tizen.crash-worker-sdk.install.in6
-rwxr-xr-xdebian/rules118
8 files changed, 153 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..e533841
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,7 @@
+crash-worker-sdk (0.1.1-0) unstable; urgency=low
+
+ * released.
+ * Git: pkgs/c/crash-worker-sdk
+ * Tag: crash-worker-sdk_0.1.1-0
+
+ -- Jeesun kim <iamjs.kim@samsung.com> Fri, 17 Feb 2012 11:00:00 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..348158d
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,12 @@
+Source: crash-worker-sdk
+Section: devel
+Priority: extra
+Maintainer: Jeesun Kim <iamjs.kim@samsung.com>
+Build-Depends: debhelper (>= 5), libappcore-efl-dev, libglib2.0-dev, libslp-setting-dev, libslp-utilx-dev, libheynoti-dev
+Standards-Version: 3.7.2
+
+Package: org.tizen.crash-worker-sdk
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: crash-worker-sdk
+
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..e36ecdf
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,6 @@
+Copyright (c) 2000 - 2012 Samsung Electronics Co., Ltd All Rights Reserved
+
+PROPRIETARY/CONFIDENTIAL
+
+This software is the confidential and proprietary information of SAMSUNG ELECTRONICS ("Confidential Information"). You shall not disclose such Confidential Information and shall use it only in accordance with the terms of the license agreement you entered into with SAMSUNG ELECTRONICS. SAMSUNG make no representations or warranties about the suitability of the software, either express or implied, including but not limited to the implied warranties of merchantability, fitness for a particular purpose, or non-infringement. SAMSUNG shall not be liable for any damages suffered by licensee as a result of using, modifying or distributing this software or its derivatives.
+
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..a0f0008
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+CMakeLists.txt
diff --git a/debian/org.tizen.crash-worker-sdk.install.in b/debian/org.tizen.crash-worker-sdk.install.in
new file mode 100644
index 0000000..7bbc99b
--- /dev/null
+++ b/debian/org.tizen.crash-worker-sdk.install.in
@@ -0,0 +1,6 @@
+#@PREFIX@/bin/*
+/usr/bin/*
+@PREFIX@/res/locale/*
+@PREFIX@/res/icons/*
+@PREFIX@/res/edje/*
+/opt/share/applications/*
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..05e7a9f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,118 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+CFLAGS ?= -Wall -g
+LDFLAGS ?=
+PREFIX ?= /opt/apps/org.tizen.crash-worker-sdk
+RESDIR ?= /opt/apps/org.tizen.crash-worker-sdk/res
+DATADIR ?= /opt/apps/org.tizen.crash-worker-sdk/data
+
+#ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+# CFLAGS += -O0
+#else
+# CFLAGS += -O2
+#endif
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ BUILD_TYPE=Debug
+else
+ BUILD_TYPE=Release
+endif
+
+LDFLAGS += -Wl,--rpath=$(PREFIX)/lib -Wl,--as-needed
+
+CMAKE_BUILD_DIR ?= $(CURDIR)/cmake_build_tmp
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && \
+ CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" cmake .. -DCMAKE_INSTALL_PREFIX="$(PREFIX)" -DCMAKE_BUILD_TYPE="$(BUILD_TYPE)"
+
+ touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ cd $(CMAKE_BUILD_DIR) && $(MAKE)
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ cat $$f > $${f%.in}; \
+ sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
+ sed -i -e "s#@RESDIR@#$(RESDIR)#g" $${f%.in}; \
+ sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
+ done
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ rm -rf $(CMAKE_BUILD_DIR)
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ rm -f $${f%.in}; \
+ done
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+# dh_installdirs
+
+ # Add here commands to install the package into debian/wavplayer.
+ cd $(CMAKE_BUILD_DIR) && $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+# dh_installchangelogs
+# dh_installdocs
+# dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure