summaryrefslogtreecommitdiff
path: root/meta-qt5
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-06-08 14:39:08 -0700
committerMauro Carvalho Chehab <mchehab@osg.samsung.com>2015-07-24 13:42:18 -0300
commit0cbdaecb016a21269ae0370f9f668ebb5cfffad0 (patch)
tree209fb9fcfffefc12935fbdbe18f05993a218f686 /meta-qt5
parentb140b8fa7b84cac25fc5ecbee1347508a028e282 (diff)
downloadtizen-distro-0cbdaecb016a21269ae0370f9f668ebb5cfffad0.tar.gz
tizen-distro-0cbdaecb016a21269ae0370f9f668ebb5cfffad0.tar.bz2
tizen-distro-0cbdaecb016a21269ae0370f9f668ebb5cfffad0.zip
qtbase: Fix build with musl
This is a generic fix to accomodate musl which is adhering to posix and doesnt have legacy to carry, so lets invert the conditional so the special legacy case of glibc is checked and else part then covers rest of cases which are newer glibc/uclibc and musl (From meta-qt5 rev: d9d1d04760430cd0e5edd1764d832860715e7b83) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Mauro Carvalho Chehab <mchehab@osg.samsung.com>
Diffstat (limited to 'meta-qt5')
-rw-r--r--meta-qt5/recipes-qt/qt5/qtbase/0014-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch35
-rw-r--r--meta-qt5/recipes-qt/qt5/qtbase_git.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-qt5/recipes-qt/qt5/qtbase/0014-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch b/meta-qt5/recipes-qt/qt5/qtbase/0014-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch
new file mode 100644
index 0000000000..dee8b35096
--- /dev/null
+++ b/meta-qt5/recipes-qt/qt5/qtbase/0014-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch
@@ -0,0 +1,35 @@
+From 8f09897de948cea8861ca95e182f442cf15a339e Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 8 Jun 2015 13:59:25 -0700
+Subject: [PATCH] linux-oe-g++: Invert conditional for defining QT_SOCKLEN_T
+
+This helps to make sure that QT_SOCKLEN_T is defined to be 'int'
+only when its glibc < 2 and not also for the libraries which may define
+it as per standards but are not glibc, e.g. musl
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ mkspecs/linux-oe-g++/qplatformdefs.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/mkspecs/linux-oe-g++/qplatformdefs.h b/mkspecs/linux-oe-g++/qplatformdefs.h
+index dd12003..8623651 100644
+--- a/mkspecs/linux-oe-g++/qplatformdefs.h
++++ b/mkspecs/linux-oe-g++/qplatformdefs.h
+@@ -86,10 +86,10 @@
+
+ #undef QT_SOCKLEN_T
+
+-#if defined(__GLIBC__) && (__GLIBC__ >= 2)
+-#define QT_SOCKLEN_T socklen_t
+-#else
++#if defined(__GLIBC__) && (__GLIBC__ < 2)
+ #define QT_SOCKLEN_T int
++#else
++#define QT_SOCKLEN_T socklen_t
+ #endif
+
+ #if defined(_XOPEN_SOURCE) && (_XOPEN_SOURCE >= 500)
+--
+2.1.4
+
diff --git a/meta-qt5/recipes-qt/qt5/qtbase_git.bb b/meta-qt5/recipes-qt/qt5/qtbase_git.bb
index ec6ea170e2..33620cbc92 100644
--- a/meta-qt5/recipes-qt/qt5/qtbase_git.bb
+++ b/meta-qt5/recipes-qt/qt5/qtbase_git.bb
@@ -21,6 +21,7 @@ SRC_URI += "\
file://0008-eglfs-fix-egl-error-for-platforms-only-supporting-on.patch \
file://0009-QOpenGLPaintDevice-sub-area-support.patch \
file://0010-Make-Qt5GuiConfigExtras.cmake-find-gl-es-include-dir.patch \
+ file://0014-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch \
"
# specific for qtbase