summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonan Le Martret <ronan@fridu.net>2014-06-19 18:48:51 +0200
committerRonan Le Martret <ronan@fridu.net>2014-06-19 18:48:51 +0200
commitca99d96e764d807b53f4803724ee6e42dac88cc6 (patch)
treeb2facf1d9d16d82511144816ddb69095994bd504
parent64711cd8a5370f11fb5ffdaefaf28556ffb505ff (diff)
parent80a89ccf19f4f700b2cc84dc1941d801ec88bd8c (diff)
downloadmeta-tizen-ca99d96e764d807b53f4803724ee6e42dac88cc6.tar.gz
meta-tizen-ca99d96e764d807b53f4803724ee6e42dac88cc6.tar.bz2
meta-tizen-ca99d96e764d807b53f4803724ee6e42dac88cc6.zip
Merge branch 'tizen' of git.vannes:/srv/git/gitcache/review.tizen.org//scm/bb/meta-tizen into tizen
-rw-r--r--recipes-image/images/tizen-common-core-image-minimal.bb2
-rw-r--r--recipes-tizen/dlog/dlog-extraconf.inc2
-rw-r--r--recipes-tizen/privacy-manager/privacy-manager.inc39
-rw-r--r--recipes-tizen/security-server/security-server-extraconf.inc20
-rw-r--r--recipes-tizen/security-server/security-server.inc121
-rw-r--r--recipes-tizen/security-server/security-server/0001-PATCH-link-to-the-pthread-library.patch29
-rw-r--r--recipes-tizen/security-server/security-server/Fix-lib-install-dir.patch79
-rw-r--r--recipes-tizen/security-server/security-server_git.bb2
8 files changed, 179 insertions, 115 deletions
diff --git a/recipes-image/images/tizen-common-core-image-minimal.bb b/recipes-image/images/tizen-common-core-image-minimal.bb
index ebe766bf..e07b30d6 100644
--- a/recipes-image/images/tizen-common-core-image-minimal.bb
+++ b/recipes-image/images/tizen-common-core-image-minimal.bb
@@ -25,4 +25,4 @@ IMAGE_INSTALL += "user-session-units"
IMAGE_INSTALL += "default-ac-domains"
IMAGE_INSTALL += "desktop-skin"
-#IMAGE_INSTALL += "crosswalk"
+IMAGE_INSTALL += "crosswalk"
diff --git a/recipes-tizen/dlog/dlog-extraconf.inc b/recipes-tizen/dlog/dlog-extraconf.inc
index e69de29b..98d32378 100644
--- a/recipes-tizen/dlog/dlog-extraconf.inc
+++ b/recipes-tizen/dlog/dlog-extraconf.inc
@@ -0,0 +1,2 @@
+SRC_URI += "file://tmp_fix_header.patch \
+ " \ No newline at end of file
diff --git a/recipes-tizen/privacy-manager/privacy-manager.inc b/recipes-tizen/privacy-manager/privacy-manager.inc
index a16a4897..f76050d2 100644
--- a/recipes-tizen/privacy-manager/privacy-manager.inc
+++ b/recipes-tizen/privacy-manager/privacy-manager.inc
@@ -12,22 +12,22 @@ inherit autotools-brokensep
BBCLASSEXTEND = ""
PROVIDES = ""
-#PROVIDES by privacy-manager-client
+#PROVIDES by privacy-manager-client
-#PROVIDES by privacy-manager-server
+#PROVIDES by privacy-manager-server
-#PROVIDES by privacy-manager-server-dev
+#PROVIDES by privacy-manager-server-dev
-#PROVIDES by capi-security-privacy-manager
+#PROVIDES by capi-security-privacy-manager
-#PROVIDES by privacy-manager-client-dev
+#PROVIDES by privacy-manager-client-dev
-#PROVIDES by capi-security-privacy-manager-dev
+#PROVIDES by capi-security-privacy-manager-dev
RDEPENDS = ""
@@ -51,7 +51,7 @@ RDEPENDS_capi-security-${PN}-dev += "capi-security-privacy-manager"
DEPENDS = ""
-#DEPENDS of privacy-manager-server
+#DEPENDS of privacy-manager-server
DEPENDS += "pkgmgr-info"
#Replace "DEPENDS" on gettext by "inherit gettext"
inherit gettext
@@ -92,10 +92,10 @@ do_compile() {
LANG=C
export LANG
unset DISPLAY
- CFLAGS="-O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables" ; export CFLAGS ;
- CXXFLAGS="${CXXFLAGS:--O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables}" ; export CXXFLAGS ;
- FFLAGS="${FFLAGS:--O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -I%_fmoddir}" ; export FFLAGS ;
- LD_AS_NEEDED=1; export LD_AS_NEEDED ;
+ CFLAGS="-O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables" ; export CFLAGS ;
+ CXXFLAGS="${CXXFLAGS:--O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables}" ; export CXXFLAGS ;
+ FFLAGS="${FFLAGS:--O2 -g -m64 -fmessage-length=0 -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -I%_fmoddir}" ; export FFLAGS ;
+ LD_AS_NEEDED=1; export LD_AS_NEEDED ;
@@ -131,8 +131,8 @@ do_install() {
LANG=C
export LANG
unset DISPLAY
- rm -rf ${D}
- mkdir -p ${D}
+ rm -rf ${D}
+ mkdir -p ${D}
mkdir -p ${D}${prefix}/bin
cp res/usr/bin/* ${D}${prefix}/bin/
@@ -203,6 +203,7 @@ pkg_postrm_privacy-manager-client() {
/sbin/ldconfig
}
+PACKAGES = "${PN}-dbg ${PN}-doc ${PN}-locale"
PACKAGES += " privacy-manager-client "
PACKAGES += " privacy-manager-server "
PACKAGES += " privacy-manager-server-dev "
@@ -241,12 +242,12 @@ capi-security-privacy-manager-dev_files += "${prefix}/include/privacymgr/*.h"
capi-security-privacy-manager-dev_files += "${prefix}/lib/libcapi-security-privacy-manager.so"
capi-security-privacy-manager-dev_files += "${prefix}/lib/pkgconfig/capi-security-privacy-manager.pc"
-FILES_privacy-manager-client = "${privacy-manager-client_files}"
-FILES_${PN} = "${privacy-manager-server_files}"
-FILES_${PN}-dev = "${privacy-manager-server-dev_files}"
-FILES_capi-security-privacy-manager = "${capi-security-privacy-manager_files}"
-FILES_privacy-manager-client-dev = "${privacy-manager-client-dev_files}"
-FILES_capi-security-privacy-manager-dev = "${capi-security-privacy-manager-dev_files}"
+FILES_${PN}-client = "${privacy-manager-client_files}"
+FILES_${PN}-server = "${privacy-manager-server_files}"
+FILES_${PN}-server-dev = "${privacy-manager-server-dev_files}"
+FILES_capi-security-${PN} = "${capi-security-privacy-manager_files}"
+FILES_${PN}-client-dev = "${privacy-manager-client-dev_files}"
+FILES_capi-security-${PN}-dev = "${capi-security-privacy-manager-dev_files}"
PKG_privacy-manager-client= "privacy-manager-client"
PKG_privacy-manager-server= "privacy-manager-server"
diff --git a/recipes-tizen/security-server/security-server-extraconf.inc b/recipes-tizen/security-server/security-server-extraconf.inc
index 083f3025..03941ab9 100644
--- a/recipes-tizen/security-server/security-server-extraconf.inc
+++ b/recipes-tizen/security-server/security-server-extraconf.inc
@@ -1,4 +1,20 @@
inherit cmake
-SRC_URI += "file://Fix-lib-install-dir.patch "
-
+
+B = "${S}"
+
+SRC_URI += "file://0001-PATCH-link-to-the-pthread-library.patch"
+
+do_configure_prepend() {
+ # Remove failing expression
+ sed -i 's!STRING(REGEX MATCH .*!!g' ${S}/CMakeLists.txt
+ sed -i 's!ADD_DEFINITIONS("-DAPI_VERSION=.*!!g' ${S}/CMakeLists.txt
+
+ # Replace undefined variables
+ find ${S} -name "CMakeLists.txt" -exec sed -i 's!\${LIB_INSTALL_DIR}!lib!g' {} \;
+ find ${S} -name "CMakeLists.txt" -exec sed -i 's!\${INCLUDE_INSTALL_DIR}!/usr/include!g' {} \;
+
+ # Replace macros that aren't automatically expanded
+ sed -i 's!@LIB_INSTALL_DIR@!${prefix}/lib!g' ${S}/build/security-server/security-server.pc.in ${S}/build/security-manager/security-manager.pc.in
+}
+
CXXFLAGS += "-std=c++11"
diff --git a/recipes-tizen/security-server/security-server.inc b/recipes-tizen/security-server/security-server.inc
index 34736735..1efade19 100644
--- a/recipes-tizen/security-server/security-server.inc
+++ b/recipes-tizen/security-server/security-server.inc
@@ -12,38 +12,51 @@ inherit autotools-brokensep
BBCLASSEXTEND = ""
PROVIDES = ""
-#PROVIDES by security-server-certs
+#PROVIDES by libsecurity-manager-client
+
+
+#PROVIDES by security-server
#PROVIDES by libsecurity-server-client
-#PROVIDES by security-server
+#PROVIDES by libsecurity-server-client-dev
+
+
+#PROVIDES by libsecurity-manager-client-dev
#PROVIDES by security-server-dev
-#PROVIDES by libsecurity-server-client-dev
+#PROVIDES by security-server-certs
RDEPENDS = ""
-#RDEPENDS of security-server-certs (${PN}-certs)
-RDEPENDS_${PN}-certs += "security-server"
+#RDEPENDS of libsecurity-manager-client (libsecurity-manager-client)
+RDEPENDS_libsecurity-manager-client += "eglibc"
+RDEPENDS_libsecurity-manager-client += "security-server"
+
+#RDEPENDS of libsecurity-server-client-dev (lib${PN}-client-dev)
+RDEPENDS_lib${PN}-client-dev += "libprivilege-control-dev"
+RDEPENDS_lib${PN}-client-dev += "libsecurity-server-client"
#RDEPENDS of libsecurity-server-client (lib${PN}-client)
RDEPENDS_lib${PN}-client += "eglibc"
RDEPENDS_lib${PN}-client += "security-server"
-#RDEPENDS of libsecurity-server-client-dev (lib${PN}-client-dev)
-RDEPENDS_lib${PN}-client-dev += "libprivilege-control-dev"
-RDEPENDS_lib${PN}-client-dev += "libsecurity-server-client"
+#RDEPENDS of security-server (${PN})
+RDEPENDS_${PN} += "systemd"
+
+#RDEPENDS of libsecurity-manager-client-dev (libsecurity-manager-client-dev)
+RDEPENDS_libsecurity-manager-client-dev += "libsecurity-manager-client"
#RDEPENDS of security-server-dev (${PN}-dev)
RDEPENDS_${PN}-dev += "security-server"
-#RDEPENDS of security-server (${PN})
-RDEPENDS_${PN} += "systemd"
+#RDEPENDS of security-server-certs (${PN}-certs)
+RDEPENDS_${PN}-certs += "security-server"
DEPENDS = ""
@@ -65,6 +78,7 @@ do_prep() {
#setup -q
cp ${S}/packaging/security-server.manifest .
cp ${S}/packaging/libsecurity-server-client.manifest .
+ cp ${S}/packaging/libsecurity-manager-client.manifest .
}
@@ -101,7 +115,7 @@ do_compile() {
-DSYSCONF_INSTALL_DIR:PATH=${sysconfdir} \
-DSHARE_INSTALL_PREFIX:PATH=${prefix}/share \
-DCMAKE_SKIP_RPATH:BOOL=ON \
- -DBUILD_SHARED_LIBS:BOOL=ON . -DVERSION=0.0.118 \
+ -DBUILD_SHARED_LIBS:BOOL=ON . -DVERSION=0.0.119 \
-DCMAKE_BUILD_TYPE=RELEASE \
-DCMAKE_VERBOSE_MAKEFILE=ON
make -j16
@@ -123,6 +137,7 @@ do_install() {
mkdir -p ${D}/usr/share/license
cp LICENSE ${D}/usr/share/license/security-server
cp LICENSE ${D}/usr/share/license/libsecurity-server-client
+ cp LICENSE ${D}/usr/share/license/libsecurity-manager-client
mkdir -p ${D}/etc/security/
cp security-server-audit.conf ${D}/etc/security/
@@ -147,13 +162,87 @@ do_install() {
ln -s ../security-server-password-check.socket ${D}/usr/lib/systemd/system/sockets.target.wants/security-server-password-check.socket
ln -s ../security-server-password-set.socket ${D}/usr/lib/systemd/system/sockets.target.wants/security-server-password-set.socket
ln -s ../security-server-password-reset.socket ${D}/usr/lib/systemd/system/sockets.target.wants/security-server-password-reset.socket
+ ln -s ../security-manager-installer.socket ${D}/usr/lib/systemd/system/sockets.target.wants/security-manager-installer.socket
}
+pkg_postinst_${PN}() {
+ #!/bin/sh -e
+
+ systemctl daemon-reload
+ if [ $1 = 1 ]; then
+ # installation
+ systemctl start security-server.service
+ fi
+ if [ $1 = 2 ]; then
+ # update
+ systemctl restart security-server.service
+ fi
+
+}
+
+pkg_postinst_libsecurity-server-client() {
+ #!/bin/sh -e
+
+ /sbin/ldconfig
+}
+
+pkg_postinst_libsecurity-manager-client() {
+ #!/bin/sh -e
+
+ /sbin/ldconfig
+}
+
+pkg_prerm_${PN}() {
+ #!/bin/sh -e
+
+ if [ $1 = 0 ]; then
+ # unistall
+ systemctl stop security-server.service
+ fi
+
+}
+
+pkg_postrm_libsecurity-manager-client() {
+ #!/bin/sh -e
+
+ /sbin/ldconfig
+}
+
+pkg_postrm_${PN}() {
+ #!/bin/sh -e
+
+ if [ $1 = 0 ]; then
+ # unistall
+ systemctl daemon-reload
+ fi
+
+}
+
+pkg_postrm_libsecurity-server-client() {
+ #!/bin/sh -e
+
+ /sbin/ldconfig
+}
+
+PACKAGES += " libsecurity-manager-client "
+PACKAGES += " libsecurity-manager-client-dev "
PACKAGES += " libsecurity-server-client "
PACKAGES += " libsecurity-server-client-dev "
+libsecurity-manager-client_files = ""
+libsecurity-manager-client_files += "libsecurity-manager-client.manifest"
+libsecurity-manager-client_files += "${prefix}/lib/libsecurity-manager-client.so.*"
+libsecurity-manager-client_files += "${prefix}/share/license/libsecurity-manager-client"
+
+libsecurity-manager-client-dev_files = ""
+libsecurity-manager-client-dev_files += "security-server.manifest"
+libsecurity-manager-client-dev_files += "${prefix}/lib/libsecurity-manager-client.so"
+libsecurity-manager-client-dev_files += "${prefix}/lib/libsecurity-server-commons.so"
+libsecurity-manager-client-dev_files += "${prefix}/include/security-manager/security-manager.h"
+libsecurity-manager-client-dev_files += "${prefix}/lib/pkgconfig/security-manager.pc"
+
security-server_files = ""
security-server_files += "security-server.manifest"
security-server_files += "/usr/bin/security-server"
@@ -180,6 +269,8 @@ security-server_files += "/usr/lib/systemd/system/sockets.target.wants/security-
security-server_files += "/usr/lib/systemd/system/security-server-password-set.socket"
security-server_files += "/usr/lib/systemd/system/sockets.target.wants/security-server-password-reset.socket"
security-server_files += "/usr/lib/systemd/system/security-server-password-reset.socket"
+security-server_files += "/usr/lib/systemd/system/sockets.target.wants/security-manager-installer.socket"
+security-server_files += "/usr/lib/systemd/system/security-manager-installer.socket"
security-server_files += "${prefix}/share/license/security-server"
libsecurity-server-client_files = ""
@@ -191,13 +282,17 @@ libsecurity-server-client-dev_files = ""
libsecurity-server-client-dev_files += "security-server.manifest"
libsecurity-server-client-dev_files += "${prefix}/lib/libsecurity-server-client.so"
libsecurity-server-client-dev_files += "${prefix}/lib/libsecurity-server-commons.so"
-libsecurity-server-client-dev_files += "/usr/include/security-server/security-server.h"
-libsecurity-server-client-dev_files += "${prefix}/lib/pkgconfig/*.pc"
+libsecurity-server-client-dev_files += "${prefix}/include/security-server/security-server.h"
+libsecurity-server-client-dev_files += "${prefix}/lib/pkgconfig/security-server.pc"
+FILES_libsecurity-manager-client = "${libsecurity-manager-client_files}"
+FILES_libsecurity-manager-client-dev = "${libsecurity-manager-client-dev_files}"
FILES_${PN} = "${security-server_files}"
FILES_lib${PN}-client = "${libsecurity-server-client_files}"
FILES_lib${PN}-client-dev = "${libsecurity-server-client-dev_files}"
+PKG_libsecurity-manager-client= "libsecurity-manager-client"
+PKG_libsecurity-manager-client-dev= "libsecurity-manager-client-dev"
PKG_security-server= "security-server"
PKG_libsecurity-server-client= "libsecurity-server-client"
PKG_libsecurity-server-client-dev= "libsecurity-server-client-dev"
diff --git a/recipes-tizen/security-server/security-server/0001-PATCH-link-to-the-pthread-library.patch b/recipes-tizen/security-server/security-server/0001-PATCH-link-to-the-pthread-library.patch
new file mode 100644
index 00000000..caa7f263
--- /dev/null
+++ b/recipes-tizen/security-server/security-server/0001-PATCH-link-to-the-pthread-library.patch
@@ -0,0 +1,29 @@
+From 48779d5214c204ba248211ba6adbf250e3114ffb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?K=C3=A9vin=20THIERRY?= <kevin.thierry@open.eurogiciel.org>
+Date: Thu, 19 Jun 2014 09:03:57 +0200
+Subject: [PATCH] [PATCH] link to the pthread library
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Kévin THIERRY <kevin.thierry@open.eurogiciel.org>
+---
+ src/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 2b9af87..1b67cc6 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -54,7 +54,7 @@ ADD_EXECUTABLE(${TARGET_SECURITY_SERVER} ${SECURITY_SERVER_SOURCES})
+ TARGET_LINK_LIBRARIES(${TARGET_SECURITY_SERVER}
+ ${SECURITY_SERVER_DEP_LIBRARIES}
+ ${TARGET_SERVER_COMMON}
+- -lcap
++ -lcap -lpthread
+ )
+
+ ################################################################################
+--
+1.8.1.4
+
diff --git a/recipes-tizen/security-server/security-server/Fix-lib-install-dir.patch b/recipes-tizen/security-server/security-server/Fix-lib-install-dir.patch
deleted file mode 100644
index 0291bafb..00000000
--- a/recipes-tizen/security-server/security-server/Fix-lib-install-dir.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-
-From 61c10122d3655e89c289f89e610230591d2d080c Mon Sep 17 00:00:00 2001
-From: Xavier Roche <xavrock.os@gmail.com>
-Date: Mon, 26 May 2014 15:51:18 +0200
-Subject: [PATCH] Fix lib install dir for Yocto build
-
-Signed-off-by: Xavier Roche <xavrock.os@gmail.com>
----
- CMakeLists.txt | 3 ---
- build/security-server/CMakeLists.txt | 2 +-
- build/security-server/security-server.pc.in | 2 +-
- src/CMakeLists.txt | 2 +-
- src/server/CMakeLists.txt | 2 +-
- 5 files changed, 4 insertions(+), 7 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 476b94a..516c6bf 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -48,9 +48,6 @@ ADD_DEFINITIONS("-Werror") # Make all warnings into errors.
- ADD_DEFINITIONS("-Wall") # Generate all warnings
- ADD_DEFINITIONS("-Wextra") # Generate even more extra warnings
-
--STRING(REGEX MATCH "([^.]*)" API_VERSION "${VERSION}")
--ADD_DEFINITIONS("-DAPI_VERSION=\"$(API_VERSION)\"")
--
- ADD_DEFINITIONS("-DSMACK_ENABLED")
-
- IF (CMAKE_BUILD_TYPE MATCHES "DEBUG")
-diff --git a/build/security-server/CMakeLists.txt b/build/security-server/CMakeLists.txt
-index ddc0fb7..d65dd3a 100644
---- a/build/security-server/CMakeLists.txt
-+++ b/build/security-server/CMakeLists.txt
-@@ -22,5 +22,5 @@ CONFIGURE_FILE(security-server.pc.in security-server.pc @ONLY)
- INSTALL(FILES
- ${CMAKE_BINARY_DIR}/build/security-server/security-server.pc
- DESTINATION
-- ${LIB_INSTALL_DIR}/pkgconfig
-+ lib/pkgconfig
- )
-diff --git a/build/security-server/security-server.pc.in b/build/security-server/security-server.pc.in
-index 608cb2d..df49caf 100644
---- a/build/security-server/security-server.pc.in
-+++ b/build/security-server/security-server.pc.in
-@@ -1,6 +1,6 @@
- prefix=@CMAKE_INSTALL_PREFIX@
- exec_prefix=${prefix}
--libdir=@LIB_INSTALL_DIR@
-+libdir=${prefix}/lib
- includedir=${prefix}/include
-
- Name: security-server
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index b0270d4..87e9b3e 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -93,7 +93,7 @@ TARGET_LINK_LIBRARIES(${TARGET_SECURITY_CLIENT}
-
- ################################################################################
-
--INSTALL(TARGETS ${TARGET_SECURITY_CLIENT} DESTINATION ${LIB_INSTALL_DIR})
-+INSTALL(TARGETS ${TARGET_SECURITY_CLIENT} DESTINATION lib)
-
- INSTALL(TARGETS ${TARGET_SECURITY_SERVER} DESTINATION bin)
-
-diff --git a/src/server/CMakeLists.txt b/src/server/CMakeLists.txt
-index 2cd6177..0fad220 100644
---- a/src/server/CMakeLists.txt
-+++ b/src/server/CMakeLists.txt
-@@ -49,5 +49,5 @@ TARGET_LINK_LIBRARIES(${TARGET_SERVER_COMMON}
-
- ################################################################################
-
--INSTALL(TARGETS ${TARGET_SERVER_COMMON} DESTINATION ${LIB_INSTALL_DIR})
-+INSTALL(TARGETS ${TARGET_SERVER_COMMON} DESTINATION lib)
-
---
-1.7.9.5
-
diff --git a/recipes-tizen/security-server/security-server_git.bb b/recipes-tizen/security-server/security-server_git.bb
index 95643d2e..3d2afae2 100644
--- a/recipes-tizen/security-server/security-server_git.bb
+++ b/recipes-tizen/security-server/security-server_git.bb
@@ -4,7 +4,7 @@ PRIORITY = "10"
LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-SRC_URI += "git://review.tizen.org/platform/core/security/security-server;tag=2ed4c64c78df05eb8f1f4ba200dafb638cc5307c;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/core/security/security-server;tag=dec63b007bbb1ce9f74b938d86a012c4a56970da;nobranch=1"
BBCLASSEXTEND += " native "