summaryrefslogtreecommitdiff
path: root/packaging/system-tools.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/system-tools.spec')
-rw-r--r--packaging/system-tools.spec33
1 files changed, 33 insertions, 0 deletions
diff --git a/packaging/system-tools.spec b/packaging/system-tools.spec
new file mode 100644
index 0000000..c933f9d
--- /dev/null
+++ b/packaging/system-tools.spec
@@ -0,0 +1,33 @@
+Name: system-tools
+Version: 0.0.1
+Release: 0
+Summary: Tizen kernel and system tools
+Group: libs
+License: Qualcomm Proprietary License
+Source0: %{name}-%{version}.tar.gz
+BuildRequires: cmake
+
+%if "%{?tizen_profile_name}" == "tv"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
+%description
+System tools includes all application related with Tizen kernel
+
+%prep
+%setup -q
+
+%build
+export LDFLAGS+="-Wl,--rpath=%{_prefix}/lib -Wl,--as-needed"
+LDFLAGS="$LDFLAGS" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+
+make
+
+%install
+
+%make_install
+
+%files
+%defattr(-,root,root,-)
+%{_bindir}/dtbtool
+%{_bindir}/mkdzimage