summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am74
1 files changed, 74 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..d3c7b01
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,74 @@
+## Copyright 2012, 2013 Intel Corporation All Rights Reserved.
+##
+## This library is free software; you can redistribute it and/or
+## modify it under the terms of the GNU Lesser General Public
+## License as published by the Free Software Foundation;
+## version 2.1 of the License.
+##
+## This library is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+## Lesser General Public License for more details.
+##
+## You should have received a copy of the GNU Lesser General Public
+## License along with this library; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin Street, Fifth Floor,
+## Boston, MA 02110-1301 USA
+
+## ---------------------------------------------------------
+## settings daemon
+## ---------------------------------------------------------
+
+# The settingsd stand-alone binary.
+bin_PROGRAMS = settingsd
+
+## Note that we define some preprocessor symbols on the command line
+## since the required shell variables cannot be fully expanded at
+## configure-time.
+settingsd_CPPFLAGS = \
+ $(BOOST_CPPFLAGS) \
+ $(GIO_CFLAGS) \
+ $(JSON_GLIB_CFLAGS) \
+ $(LIBWEBSOCKETS_CFLAGS) \
+ -I$(top_srcdir)/include \
+ -DIVI_SETTINGS_CONFIG_DIR='"$(sysconfdir)/@PACKAGE@"' \
+ -DIVI_SETTINGS_DEFAULT_SETTINGS_DIR='"$(pkglibdir)"'
+
+settingsd_SOURCES = \
+ configurator.cpp \
+ daemon.cpp \
+ websocket_server.cpp
+
+settingsd_LDFLAGS = $(BOOST_LDFLAGS)
+
+settingsd_LDADD = \
+ $(top_builddir)/lib/libsettings.la \
+ $(BOOST_PROGRAM_OPTIONS_LIB) \
+ $(JSON_GLIB_LIBS) \
+ $(GIO_LIBS) \
+ $(LIBWEBSOCKETS_LIBS) \
+ @IVI_SETTINGS_DLOPEN_LIBS@
+
+noinst_HEADERS = \
+ configurator.hpp \
+ websocket_server.hpp
+
+
+## Silent mode output for D-bus related code generation.
+dbus_codegen_verbose = $(dbus_codegen_verbose_$(V))
+dbus_codegen_verbose_ = $(dbus_codegen_verbose_$(AM_DEFAULT_VERBOSITY))
+dbus_codegen_verbose_0 = @echo 'CODEGEN ' $@;
+
+## Geocoding related D-bus glue code generation.
+%-glue.c %-glue.h: %.xml Makefile
+ $(dbus_codegen_verbose)gdbus-codegen --generate-c-code $*-glue \
+ --interface-prefix org.tizen. $<
+
+BUILT_SOURCES =
+
+CLEANFILES = $(BUILT_SOURCES)
+
+dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)
+
+EXTRA_DIST =