summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index fd4d9d8..2c7599b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,14 +102,7 @@ AC_SUBST([LIBWEBSOCKETS_CFLAGS])
# Checks for typedefs, structures, and compiler characteristics.
# Check for C++11 support. (macro from autoconf-archive package)
-AX_CXX_COMPILE_STDCXX_0X
-AS_IF([test "x$ax_cv_cxx_compile_cxx0x_cxx" = "xyes"],
- [CXXFLAGS="-std=c++0x $CXXFLAGS"],
- [AS_IF([test "x$ax_cv_cxx_compile_cxx0x_gxx" = "xyes"],
- [CXXFLAGS="-std=gnu++0x $CXXFLAGS"],
- [AC_MSG_FAILURE([Required C++11 support is not available.])
- ])
- ])
+AX_CXX_COMPILE_STDCXX_11([noext],[mandatory])
# Enable gcc symbol visibility support.
AC_LANG_PUSH([C++])