summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Meerwald <p.meerwald@bct-electronic.com>2011-12-11 16:07:42 +0100
committerArun Raghavan <arun.raghavan@collabora.co.uk>2011-12-13 09:16:32 +0530
commitdc5a39b124b6dd605d88e8633bd93e3da1169c3d (patch)
treeec7a669f48b3c14d944c8cdf2dad8995e22bec01 /configure.ac
parent5f2286e6f76ab9fbf83a92c17b48b537d9d59026 (diff)
downloadpulseaudio-panda-dc5a39b124b6dd605d88e8633bd93e3da1169c3d.tar.gz
pulseaudio-panda-dc5a39b124b6dd605d88e8633bd93e3da1169c3d.tar.bz2
pulseaudio-panda-dc5a39b124b6dd605d88e8633bd93e3da1169c3d.zip
echo-cance: Make Adrian canceller optional
makes the Adrian echo canceller implementation optional at compile time this patch supersedes an earlier patch proposal and addresses the following comments: * separate patch from speex dependency rework (Arun) * check that at least one EC implementation is available (Arun) * properly align yes/no in configure summary for Adrian (Frederic)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dcf4b8fd..af30fd3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1178,6 +1178,13 @@ AC_SUBST(WEBRTC_CFLAGS)
AC_SUBST(WEBRTC_LIBS)
AM_CONDITIONAL([HAVE_WEBRTC], [test "x$HAVE_WEBRTC" = "x1"])
+AC_ARG_ENABLE([adrian-aec],
+ AS_HELP_STRING([--enable-adrian-aec], [Enable Adrian's optional echo canceller]))
+AS_IF([test "x$enable_adrian_aec" != "xno"],
+ [HAVE_ADRIAN_EC=1])
+AM_CONDITIONAL([HAVE_ADRIAN_EC], [test "x$HAVE_ADRIAN_EC" = "x1"])
+
+
###################################
# Output #
@@ -1324,6 +1331,7 @@ AS_IF([test "x$HAVE_IPV6" = "x1"], ENABLE_IPV6=yes, ENABLE_IPV6=no)
AS_IF([test "x$HAVE_OPENSSL" = "x1"], ENABLE_OPENSSL=yes, ENABLE_OPENSSL=no)
AS_IF([test "x$HAVE_FFTW" = "x1"], ENABLE_FFTW=yes, ENABLE_FFTW=no)
AS_IF([test "x$HAVE_ORC" = "xyes"], ENABLE_ORC=yes, ENABLE_ORC=no)
+AS_IF([test "x$HAVE_ADRIAN_EC" = "x1"], ENABLE_ADRIAN_EC=yes, ENABLE_ADRIAN_EC=no)
AS_IF([test "x$HAVE_SPEEX" = "x1"], ENABLE_SPEEX=yes, ENABLE_SPEEX=no)
AS_IF([test "x$HAVE_WEBRTC" = "x1"], ENABLE_WEBRTC=yes, ENABLE_WEBRTC=no)
AS_IF([test "x$HAVE_TDB" = "x1"], ENABLE_TDB=yes, ENABLE_TDB=no)
@@ -1372,7 +1380,8 @@ echo "
Enable OpenSSL (for Airtunes): ${ENABLE_OPENSSL}
Enable fftw: ${ENABLE_FFTW}
Enable orc: ${ENABLE_ORC}
- Enable speex: ${ENABLE_SPEEX}
+ Enable Adrian echo canceller: ${ENABLE_ADRIAN_EC}
+ Enable speex (resampler, AEC): ${ENABLE_SPEEX}
Enable WebRTC echo canceller: ${ENABLE_WEBRTC}
Database
tdb: ${ENABLE_TDB}
@@ -1390,6 +1399,10 @@ echo "
Legacy Database Entry Support: ${ENABLE_LEGACY_DATABASE_ENTRY_FORMAT}
"
+if test "${ENABLE_SPEEX}" = "no" && test "${ENABLE_WEBRTC}" = "no" && test "${ENABLE_ADRIAN_EC}" = "no" ; then
+AC_MSG_ERROR([At least one echo canceller implementation must be available.])
+fi
+
if test "${ENABLE_DBUS}" = "no" && test "x$os_is_win32" != "x1" ; then
echo "
===== WARNING WARNING WARNING WARNING WARNING WARNING WARNING =====