summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Guthrie <colin@mageia.org>2011-10-11 20:42:42 +0100
committerColin Guthrie <colin@mageia.org>2011-10-19 23:49:23 +0100
commitce546b22ebb5a4806b2745cfeddb0d740a6aa3a8 (patch)
tree34655bb42fcd826a4063878db220f089fbb30d49 /configure.ac
parent034006ec90a070ee309ef7b16247ac9c9501cf03 (diff)
downloadpulseaudio-panda-ce546b22ebb5a4806b2745cfeddb0d740a6aa3a8.tar.gz
pulseaudio-panda-ce546b22ebb5a4806b2745cfeddb0d740a6aa3a8.tar.bz2
pulseaudio-panda-ce546b22ebb5a4806b2745cfeddb0d740a6aa3a8.zip
build-sys: Provide a simple CMake Config setup (similar to pkgconfig)
I'd rather not have to do this, as I don't really see the point in duplicating what is done in pkgconfig, but this is likely the easiest way to avoid nasty hacks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index feeae755..9322ca0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -779,6 +779,7 @@ AS_IF([test "x$enable_glib2" = "xyes" && test "x$HAVE_GLIB20" = "x0"],
AC_SUBST(GLIB20_CFLAGS)
AC_SUBST(GLIB20_LIBS)
+AC_SUBST(HAVE_GLIB20)
AM_CONDITIONAL([HAVE_GLIB20], [test "x$HAVE_GLIB20" = x1])
AS_IF([test "x$HAVE_GLIB20" = "x1"], AC_DEFINE([HAVE_GLIB], 1, [Have GLIB?]))
@@ -1263,6 +1264,16 @@ AC_CONFIG_FILES([src/default.pa:src/daemon/default.pa.in],
AC_CONFIG_FILES([src/system.pa:src/daemon/system.pa.in],
[m4 src/system.pa > src/system.pa.gen && mv src/system.pa.gen src/system.pa])
+# CMake related ProjectConfig files
+PA_LIBDIR="$libdir"
+AX_DEFINE_DIR(PA_LIBDIR, PA_LIBDIR, [PulseAudio library dir])
+PA_INCDIR="$includedir"
+AX_DEFINE_DIR(PA_INCDIR, PA_INCDIR, [PulseAudio include dir])
+
+AC_CONFIG_FILES([PulseAudioConfig.cmake:PulseAudioConfig.cmake.in],
+ [m4 PulseAudioConfig.cmake > PulseAudioConfig.cmake.gen && mv PulseAudioConfig.cmake.gen PulseAudioConfig.cmake])
+AC_CONFIG_FILES([PulseAudioConfigVersion.cmake])
+
AC_OUTPUT
# ==========================================================================