summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNakamura Hayato <hayato.nakamura@mail.toyota-td.jp>2013-07-29 14:33:50 +0900
committerNakamura Hayato <hayato.nakamura@mail.toyota-td.jp>2013-07-29 14:36:22 +0900
commitd6c07c6cc58188a6c913fd5285b716657466caad (patch)
tree65f1e7eaa9c47ff370b7bb5aa9540ed75ec99e91 /src/Makefile.am
parenta734dfb193f61d7235fdd50e5e12b816dd1f26dd (diff)
downloadico-uxf-weston-plugin-d6c07c6cc58188a6c913fd5285b716657466caad.tar.gz
ico-uxf-weston-plugin-d6c07c6cc58188a6c913fd5285b716657466caad.tar.bz2
ico-uxf-weston-plugin-d6c07c6cc58188a6c913fd5285b716657466caad.zip
Support Tizen 3.0
Change-Id: Icefff6e8437189cab41f9465919d09e3c97a0988 Signed-off-by: Nakamura Hayato <hayato.nakamura@mail.toyota-td.jp>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am77
1 files changed, 45 insertions, 32 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 784549f..26e6570 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,14 +1,19 @@
lib_LTLIBRARIES = libico-uxf-weston-plugin.la
pkginclude_HEADERS = \
- ico_ivi_shell-client-protocol.h \
+ desktop-shell-client-protocol.h \
+ input-method-client-protocol.h \
+ workspaces-client-protocol.h \
ico_window_mgr-client-protocol.h \
- ico_input_mgr-client-protocol.h
+ ico_input_mgr-client-protocol.h \
+ ico_input_mgr.h
libico_uxf_weston_plugin_la_LIBADD = -lrt -lm
-libico_uxf_weston_plugin_la_LDFLAGS = -version-info 0:5:0
+libico_uxf_weston_plugin_la_LDFLAGS = -version-info 0:7:0
libico_uxf_weston_plugin_la_SOURCES = \
- ico_ivi_shell-protocol.c \
+ desktop-shell-protocol.c \
+ input-method-protocol.c \
+ workspaces-protocol.c \
ico_window_mgr-protocol.c \
ico_input_mgr-protocol.c
@@ -29,7 +34,6 @@ git-version.h : .FORCE
moduledir = @libdir@/weston
module_LTLIBRARIES = \
$(ico_plugin_loader) \
- $(ico_ivi_common) \
$(ico_ivi_shell) \
$(ico_window_mgr) \
$(ico_window_animation) \
@@ -40,18 +44,9 @@ ico_plugin_loader = ico_plugin_loader.la
ico_plugin_loader_la_LDFLAGS = -module -avoid-version
ico_plugin_loader_la_LIBADD = $(PLUGIN_LIBS)
ico_plugin_loader_la_CFLAGS = $(GCC_CFLAGS) $(EXT_CFLAGS) $(PLUGIN_CFLAGS)
-ico_plugin_loader_la_SOURCES = \
- ico_plugin_loader.c \
- config-parser.c # Remove once Weston SDK exports config functions.
-
-# IVI Common Functions
-ico_ivi_common = ico_ivi_common.la
-ico_ivi_common_la_LDFLAGS = -module -avoid-version
-ico_ivi_common_la_LIBADD = $(PLUGIN_LIBS)
-ico_ivi_common_la_CFLAGS = $(GCC_CFLAGS) $(EXT_CFLAGS) $(PLUGIN_CFLAGS)
-ico_ivi_common_la_SOURCES = \
- ico_ivi_common.c \
- config-parser.c # Remove once Weston SDK exports config functions.
+ico_plugin_loader_la_SOURCES = \
+ ico_plugin_loader.c \
+ ico_ivi_common.h
# IVI-Shell
ico_ivi_shell = ico_ivi_shell.la
@@ -59,10 +54,15 @@ ico_ivi_shell_la_LDFLAGS = -module -avoid-version
ico_ivi_shell_la_LIBADD = $(PLUGIN_LIBS)
ico_ivi_shell_la_CFLAGS = $(GCC_CFLAGS) $(EXT_CFLAGS) $(PLUGIN_CFLAGS)
ico_ivi_shell_la_SOURCES = \
- ico_ivi_shell.c \
- ico_ivi_shell-protocol.c \
- ico_ivi_shell-server-protocol.h \
- config-parser.c # Remove once Weston SDK exports config functions.
+ ico_ivi_shell.c \
+ ico_ivi_shell.h \
+ ico_ivi_common.h \
+ desktop-shell-protocol.c \
+ input-method-protocol.c \
+ workspaces-protocol.c \
+ desktop-shell-server-protocol.h \
+ input-method-server-protocol.h \
+ workspaces-server-protocol.h
# Multi Window Manager
ico_window_mgr = ico_window_mgr.la
@@ -70,7 +70,10 @@ ico_window_mgr_la_LDFLAGS = -module -avoid-version
ico_window_mgr_la_LIBADD = $(PLUGIN_LIBS) $(AUL_LIBS)
ico_window_mgr_la_CFLAGS = $(GCC_CFLAGS) $(EXT_CFLAGS) $(PLUGIN_CFLAGS)
ico_window_mgr_la_SOURCES = \
- ico_window_mgr.c \
+ ico_window_mgr.c \
+ ico_window_mgr.h \
+ ico_ivi_common.h \
+ ico_ivi_shell.h \
ico_window_mgr-protocol.c \
ico_window_mgr-server-protocol.h
#
@@ -79,8 +82,10 @@ ico_window_animation = ico_window_animation.la
ico_window_animation_la_LDFLAGS = -module -avoid-version
ico_window_animation_la_LIBADD = $(PLUGIN_LIBS) $(AUL_LIBS)
ico_window_animation_la_CFLAGS = $(GCC_CFLAGS) $(EXT_CFLAGS) $(PLUGIN_CFLAGS)
-ico_window_animation_la_SOURCES = \
- ico_window_animation.c
+ico_window_animation_la_SOURCES = \
+ ico_window_animation.c \
+ ico_window_mgr.h \
+ ico_ivi_common.h
# Multi Input Manager
ico_input_mgr = ico_input_mgr.la
@@ -88,22 +93,30 @@ ico_input_mgr_la_LDFLAGS = -module -avoid-version
ico_input_mgr_la_LIBADD = $(PLUGIN_LIBS)
ico_input_mgr_la_CFLAGS = $(GCC_CFLAGS) $(EXT_CFLAGS) $(PLUGIN_CFLAGS)
ico_input_mgr_la_SOURCES = \
- ico_input_mgr.c \
+ ico_input_mgr.c \
+ ico_input_mgr.h \
+ ico_window_mgr.h \
+ ico_ivi_common.h \
ico_input_mgr-protocol.c \
ico_input_mgr-server-protocol.h
# Wayland protocol(Build by wayland-scanner)
-BUILT_SOURCES = \
- ico_ivi_shell-protocol.c \
- ico_ivi_shell-server-protocol.h \
- ico_ivi_shell-client-protocol.h \
+BUILT_SOURCES = \
+ desktop-shell-protocol.c \
+ desktop-shell-server-protocol.h \
+ desktop-shell-client-protocol.h \
+ input-method-protocol.c \
+ input-method-server-protocol.h \
+ input-method-client-protocol.h \
+ workspaces-protocol.c \
+ workspaces-server-protocol.h \
+ workspaces-client-protocol.h \
ico_window_mgr-protocol.c \
ico_window_mgr-server-protocol.h \
ico_window_mgr-client-protocol.h \
ico_input_mgr-protocol.c \
- ico_input_mgr-server-protocol.h \
- ico_input_mgr-client-protocol.h \
- git-version.h
+ ico_input_mgr-server-protocol.h \
+ ico_input_mgr-client-protocol.h
CLEANFILES = $(BUILT_SOURCES)