summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..efbc92a
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,11 @@
+SUBDIRS = common daemon db plugins
+
+VALGRIND_TESTS_DISABLE =
+valgrind: $(SUBDIRS)
+ for t in $(filter-out $(VALGRIND_TESTS_DISABLE),$(SUBDIRS)); do \
+ cd $$t; $(MAKE) valgrind; cd ..;\
+ done;
+
+EXTRA_DIST = \
+ valgrind.supp \
+ valgrind_common.mk \ No newline at end of file