summaryrefslogtreecommitdiff
path: root/src/extensions/tizen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/extensions/tizen/Makefile.am')
-rw-r--r--src/extensions/tizen/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/extensions/tizen/Makefile.am b/src/extensions/tizen/Makefile.am
new file mode 100644
index 0000000..bab7a13
--- /dev/null
+++ b/src/extensions/tizen/Makefile.am
@@ -0,0 +1,25 @@
+include $(top_srcdir)/common.mk
+extensions_LTLIBRARIES = libextension-tizen.la
+
+libextension_tizen_la_CPPFLAGS = \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/include \
+ $(GSIGNOND_CFLAGS) \
+ $(LIBSMACK_CFLAGS) \
+ $(LIBECRYPTFS_CFLAGS)
+
+libextension_tizen_la_LIBADD = \
+ $(GSIGNOND_LIBS) \
+ $(LIBSMACK_LIBS) \
+ $(LIBECRYPTFS_LIBS)
+
+libextension_tizen_la_SOURCES = \
+ tizen-access-control-manager.h \
+ tizen-access-control-manager.c \
+ tizen-extension.h \
+ tizen-extension.c \
+ tizen-secret-storage.h \
+ tizen-secret-storage.c \
+ tizen-storage-manager.h \
+ tizen-storage-manager.c
+