summaryrefslogtreecommitdiff
path: root/src/daemon/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/daemon/plugins/Makefile.am')
-rw-r--r--src/daemon/plugins/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/daemon/plugins/Makefile.am b/src/daemon/plugins/Makefile.am
new file mode 100644
index 0000000..1892a6a
--- /dev/null
+++ b/src/daemon/plugins/Makefile.am
@@ -0,0 +1,26 @@
+SUBDIRS = plugind
+
+lib_LTLIBRARIES = libgsignond-plugins.la
+
+libgsignond_plugins_la_CPPFLAGS = \
+ -I$(top_builddir) \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/src \
+ $(GSIGNOND_CFLAGS)
+
+libgsignond_plugins_la_LIBADD = \
+ $(top_builddir)/src/common/libgsignond-common.la \
+ $(top_builddir)/src/daemon/dbus/libgsignond-dbus-glue.la \
+ $(GSIGNOND_LIBS)
+
+libgsignond_plugins_la_SOURCES = \
+ gsignond-plugin-proxy.h \
+ gsignond-plugin-proxy.c \
+ gsignond-plugin-proxy-factory.h \
+ gsignond-plugin-proxy-factory.c \
+ gsignond-plugin-remote-private.h \
+ gsignond-plugin-remote.h \
+ gsignond-plugin-remote.c
+
+CLEANFILES =