summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrey Klimenko <and.klimenko@samsung.com>2014-08-18 16:40:25 +0900
committerAndrey Klimenko <and.klimenko@samsung.com>2014-08-18 16:44:21 +0900
commit0eda78b65a791d1bcf6475f55eb8fbb2ed3d9cef (patch)
tree85e7eea588ccfdf298c084c2891c94d808f68a8c /configure.ac
parent939e9a95cb7e715685988f58e443c1b8b381cb82 (diff)
downloadx11-common-0eda78b65a791d1bcf6475f55eb8fbb2ed3d9cef.tar.gz
x11-common-0eda78b65a791d1bcf6475f55eb8fbb2ed3d9cef.tar.bz2
x11-common-0eda78b65a791d1bcf6475f55eb8fbb2ed3d9cef.zip
added Xorg startup configuration filesHEADmaster
Change-Id: I2d5cfa1a4a04a6ff11f324bd14b85ae5fcc8dbbc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac56
1 files changed, 56 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..ac85e15
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,56 @@
+# Copyright (c) 2011 Samsung Electronics Co., Ltd All Rights Reserved
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+#
+
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.61)
+AC_INIT(FULL-PACKAGE-NAME, VERSION, BUG-REPORT-ADDRESS)
+
+# Checks for programs.
+AC_PROG_INSTALL
+AC_PROG_MAKE_SET
+
+AC_CONFIG_SRCDIR([Makefile.am])
+AM_CONFIG_HEADER([config.h])
+AC_CONFIG_AUX_DIR(.)
+
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+AM_MAINTAINER_MODE
+
+# Checks for programs.
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+AC_PROG_CC
+
+AC_ARG_WITH(arch, AS_HELP_STRING([--with-arch=ARCH], [Architecture (default: arm)]),
+ [ ARCH="$withval" ],
+ [ ARCH="arm" ])
+AC_ARG_WITH(conf-prefix, AS_HELP_STRING([--with-conf-prefix=CONF_PREFIX], [Architecture (default: /usr/lib/systemd/system)]),
+ [ CONF_PREFIX="$withval" ],
+ [ CONF_PREFIX="/usr/lib/systemd/system" ])
+
+AC_SUBST(ARCH)
+AC_SUBST(CONF_PREFIX)
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT