summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 000000000..96c87f824
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,38 @@
+stress_TESTS = \
+ basic-fillrect \
+ basic-rectangle \
+ basic-string \
+ basic-copyarea \
+ basic-copyarea-size \
+ basic-putimage \
+ basic-lines \
+ basic-stress \
+ render-fill \
+ render-trapezoid \
+ render-trapezoid-image \
+ render-fill-copy \
+ render-composite-solid \
+ render-copyarea \
+ render-copyarea-size \
+ render-copy-alphaless \
+ mixed-stress \
+ dri2-swap \
+ $(NULL)
+
+check_PROGRAMS = $(stress_TESTS)
+
+AM_CFLAGS = @CWARNFLAGS@ @X11_CFLAGS@ @DRM_CFLAGS@
+LDADD = libtest.la @X11_LIBS@ -lXfixes @DRM_LIBS@ -lrt
+
+noinst_LTLIBRARIES = libtest.la
+libtest_la_SOURCES = \
+ test.h \
+ test_display.c \
+ test_image.c \
+ test_log.c \
+ test_render.c \
+ dri2.c \
+ dri2.h \
+ $(NULL)
+
+EXTRA_DIST = README