summaryrefslogtreecommitdiff
path: root/src/legacy/i810/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/legacy/i810/Makefile.am')
-rw-r--r--src/legacy/i810/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/legacy/i810/Makefile.am b/src/legacy/i810/Makefile.am
new file mode 100644
index 000000000..51489b8c5
--- /dev/null
+++ b/src/legacy/i810/Makefile.am
@@ -0,0 +1,43 @@
+SUBDIRS = xvmc
+
+noinst_LTLIBRARIES = liblegacy-i810.la
+
+AM_CFLAGS = @CWARNFLAGS@ @XORG_CFLAGS@ @DRM_CFLAGS@ @DRI_CFLAGS@ @PCIACCESS_CFLAGS@ \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/legacy \
+ $(NULL)
+
+liblegacy_i810_la_SOURCES = \
+ i810_accel.c \
+ i810_common.h \
+ i810_cursor.c \
+ i810_driver.c \
+ i810.h \
+ i810_memory.c \
+ i810_reg.h \
+ i810_ring.h \
+ i810_video.c \
+ i810_wmark.c
+
+if XAA
+liblegacy_i810_la_SOURCES += \
+ i810_xaa.c
+endif
+
+if DGA
+liblegacy_i810_la_SOURCES += \
+ i810_dga.c
+endif
+
+if DRI
+liblegacy_i810_la_SOURCES +=\
+ i810_dri.c \
+ i810_dri.h \
+ $(NULL)
+
+if XVMC
+liblegacy_i810_la_SOURCES += \
+ i810_hwmc.c \
+ $(NULL)
+endif
+endif