summaryrefslogtreecommitdiff
path: root/packaging/xdelta3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/xdelta3.spec')
-rw-r--r--packaging/xdelta3.spec10
1 files changed, 8 insertions, 2 deletions
diff --git a/packaging/xdelta3.spec b/packaging/xdelta3.spec
index 2063764..b81515a 100644
--- a/packaging/xdelta3.spec
+++ b/packaging/xdelta3.spec
@@ -28,14 +28,20 @@ develop applications that use xdelta3.
%setup -q
%build
+export CFLAGS="$CFLAGS -fPIE"
+export CXXFLAGS="$CXXFLAGS -fPIE"
+export LDFLAGS
cp %{SOURCE1} .
libtoolize -c -f
aclocal
autoheader
autoconf
automake -a -c
-./configure --prefix="/usr"
-make %{?jobs:-j%jobs} xdelta3
+%configure \
+ --prefix="/usr" \
+ LDFLAGS="$LDFLAGS -pie"
+
+make %{?jobs:-j%jobs}
%install
rm -rf %{buildroot}