summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorJoonbum Ko <joonbum.ko@samsung.com>2021-09-03 10:54:31 +0900
committerJoonbum Ko <joonbum.ko@samsung.com>2021-09-03 10:54:31 +0900
commite18b628b1500422063af7e1cd7efbc8fea0da8c1 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /man/meson.build
parentc77bce894fed3ed254af6e151570add08e68447c (diff)
downloadweston-e18b628b1500422063af7e1cd7efbc8fea0da8c1.tar.gz
weston-e18b628b1500422063af7e1cd7efbc8fea0da8c1.tar.bz2
weston-e18b628b1500422063af7e1cd7efbc8fea0da8c1.zip
Made clean this branch to use other purpose.
Change-Id: I2578c655bd3e4e03c1cdbef43c6016b4cde7b9d4 Signed-off-by: Joonbum Ko <joonbum.ko@samsung.com>
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build55
1 files changed, 0 insertions, 55 deletions
diff --git a/man/meson.build b/man/meson.build
deleted file mode 100644
index a2b8edc2..00000000
--- a/man/meson.build
+++ /dev/null
@@ -1,55 +0,0 @@
-man_conf = configuration_data()
-man_conf.set('weston_native_backend', opt_backend_native)
-man_conf.set('weston_modules_dir', dir_module_weston)
-man_conf.set('libweston_modules_dir', dir_module_libweston)
-man_conf.set('weston_shell_client', get_option('desktop-shell-client-default'))
-man_conf.set('weston_libexecdir', dir_libexec)
-man_conf.set('weston_bindir', dir_bin)
-man_conf.set('xserver_path', get_option('xwayland-path'))
-man_conf.set('version', version_weston)
-
-configure_file(
- input: 'weston.man',
- output: 'weston.1',
- install_dir: join_paths(dir_man, 'man1'),
- configuration: man_conf
-)
-
-configure_file(
- input: 'weston-bindings.man',
- output: 'weston-bindings.7',
- install_dir: join_paths(dir_man, 'man7'),
- configuration: man_conf
-)
-
-configure_file(
- input: 'weston-debug.man',
- output: 'weston-debug.1',
- install_dir: join_paths(dir_man, 'man1'),
- configuration: man_conf
-)
-
-configure_file(
- input: 'weston.ini.man',
- output: 'weston.ini.5',
- install_dir: join_paths(dir_man, 'man5'),
- configuration: man_conf
-)
-
-if get_option('backend-drm')
- configure_file(
- input: 'weston-drm.man',
- output: 'weston-drm.7',
- install_dir: join_paths(dir_man, 'man7'),
- configuration: man_conf
- )
-endif
-
-if get_option('backend-rdp')
- configure_file(
- input: 'weston-rdp.man',
- output: 'weston-rdp.7',
- install_dir: join_paths(dir_man, 'man7'),
- configuration: man_conf
- )
-endif