summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarkus Ongyerth <wl@ongy.net>2018-04-30 11:35:49 +0200
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2018-05-29 13:33:13 +0300
commitccdc81d609b38424f38bcdcb015acf69e9a009c4 (patch)
treef38302d4ade3520ce34dff555a0cbfd59ecdcd74 /Makefile.am
parente0dc5d47cb5f29deec495efd958fcd5f6f833389 (diff)
downloadweston-ccdc81d609b38424f38bcdcb015acf69e9a009c4.tar.gz
weston-ccdc81d609b38424f38bcdcb015acf69e9a009c4.tar.bz2
weston-ccdc81d609b38424f38bcdcb015acf69e9a009c4.zip
weston-info: Add support for tablet-unstable-v2
This now prints each tablet seat with at least one tablet/pad/tool attached. For each tablet seat, each tablet, pad and tool is printed with as much detail about the device as the protocol provides. Seat info is stored to be referenced, because the protocol requires to request a tablet_seat for each wl_seat and it's not guaranteed that the tablet_v2_manager is available when seats are advertised. Signed-off-by: Markus Ongyerth <wl@ongy.net> Acked-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 64a8006c..d9c03fef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -825,11 +825,13 @@ weston_simple_im_CFLAGS = $(AM_CFLAGS) $(CLIENT_CFLAGS)
weston_info_SOURCES = \
clients/weston-info.c \
shared/helpers.h
-nodist_weston_info_SOURCES = \
- protocol/presentation-time-protocol.c \
- protocol/presentation-time-client-protocol.h \
- protocol/linux-dmabuf-unstable-v1-protocol.c \
- protocol/linux-dmabuf-unstable-v1-client-protocol.h
+nodist_weston_info_SOURCES = \
+ protocol/presentation-time-protocol.c \
+ protocol/presentation-time-client-protocol.h \
+ protocol/linux-dmabuf-unstable-v1-protocol.c \
+ protocol/linux-dmabuf-unstable-v1-client-protocol.h \
+ protocol/tablet-unstable-v2-protocol.c \
+ protocol/tablet-unstable-v2-client-protocol.h
weston_info_LDADD = $(WESTON_INFO_LIBS) libshared.la
weston_info_CFLAGS = $(AM_CFLAGS) $(CLIENT_CFLAGS)
@@ -889,6 +891,8 @@ BUILT_SOURCES += \
protocol/ivi-application-client-protocol.h \
protocol/linux-dmabuf-unstable-v1-protocol.c \
protocol/linux-dmabuf-unstable-v1-client-protocol.h \
+ protocol/tablet-unstable-v2-protocol.c \
+ protocol/tablet-unstable-v2-client-protocol.h \
protocol/input-timestamps-unstable-v1-protocol.c \
protocol/input-timestamps-unstable-v1-client-protocol.h