summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexandros Frantzis <alexandros.frantzis@collabora.com>2018-02-16 18:44:15 +0200
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2018-02-20 10:20:29 +0200
commitc3b5d78c1dcc500fca8ff6d6c0f30cdaef277ec5 (patch)
treeb8d8556a33bb2bb19541cba14dbc5c79ee68d560 /Makefile.am
parent7a93bb2f17137d1f97e66904cea9ea5e5f408d2a (diff)
downloadweston-c3b5d78c1dcc500fca8ff6d6c0f30cdaef277ec5.tar.gz
weston-c3b5d78c1dcc500fca8ff6d6c0f30cdaef277ec5.tar.bz2
weston-c3b5d78c1dcc500fca8ff6d6c0f30cdaef277ec5.zip
tests: Introduce input timestamps helper
Introduce helper test code to implement the client side of the input_timestamps_unstable_v1 protocol. This helper will be used in upcoming commits to test the server side implementation of the protocol in libweston. The input_timestamps_unstable_v1 protocol was introduced in version 1.13 of wayland-protocols, so this commit updates the version dependency in configure.ac accordingly. Signed-off-by: Alexandros Frantzis <alexandros.frantzis@collabora.com> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index b5c29c04..679e6b78 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -879,7 +879,9 @@ BUILT_SOURCES += \
protocol/ivi-application-protocol.c \
protocol/ivi-application-client-protocol.h \
protocol/linux-dmabuf-unstable-v1-protocol.c \
- protocol/linux-dmabuf-unstable-v1-client-protocol.h
+ protocol/linux-dmabuf-unstable-v1-client-protocol.h \
+ protocol/input-timestamps-unstable-v1-protocol.c \
+ protocol/input-timestamps-unstable-v1-client-protocol.h
westondatadir = $(datadir)/weston
dist_westondata_DATA = \
@@ -1335,10 +1337,14 @@ vertex_clip_test_LDADD = libtest-runner.la -lm $(CLOCK_GETTIME_LIBS)
libtest_client_la_SOURCES = \
tests/weston-test-client-helper.c \
- tests/weston-test-client-helper.h
-nodist_libtest_client_la_SOURCES = \
- protocol/weston-test-protocol.c \
- protocol/weston-test-client-protocol.h
+ tests/weston-test-client-helper.h \
+ tests/input-timestamps-helper.c \
+ tests/input-timestamps-helper.h
+nodist_libtest_client_la_SOURCES = \
+ protocol/weston-test-protocol.c \
+ protocol/weston-test-client-protocol.h \
+ protocol/input-timestamps-unstable-v1-protocol.c \
+ protocol/input-timestamps-unstable-v1-client-protocol.h
libtest_client_la_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS) $(CAIRO_CFLAGS)
libtest_client_la_LIBADD = libshared.la libtest-runner.la $(TEST_CLIENT_LIBS) $(CAIRO_LIBS)