summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-11-23 11:46:57 +0200
committerDaniel Stone <daniels@collabora.com>2016-11-23 10:17:22 +0000
commit9f3d95e0d7e3c6453ddf149c1b62439c70d80ddf (patch)
tree2e40078516b09afc055a59d8d7ffe0aa5dfe5344 /Makefile.am
parent2b685d9de939d7ab3886882d1f816c26abbf25c1 (diff)
downloadweston-9f3d95e0d7e3c6453ddf149c1b62439c70d80ddf.tar.gz
weston-9f3d95e0d7e3c6453ddf149c1b62439c70d80ddf.tar.bz2
weston-9f3d95e0d7e3c6453ddf149c1b62439c70d80ddf.zip
build: fix wayland-backend distcheck
Fix the following error from 'make distcheck': CC libweston/wayland_backend_la-compositor-wayland.lo ../../libweston/compositor-wayland.c:54:51: fatal error: xdg-shell-unstable-v6-client-protocol.h: No such file or directory #include "xdg-shell-unstable-v6-client-protocol.h" Files generated with the scanner belong in nodist_*_SOURCES, not with the regular sources. Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index b90c4c82..b7eefd86 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -394,12 +394,12 @@ wayland_backend_la_CFLAGS = \
wayland_backend_la_SOURCES = \
libweston/compositor-wayland.c \
libweston/compositor-wayland.h \
- protocol/xdg-shell-unstable-v6-protocol.c \
- protocol/xdg-shell-unstable-v6-client-protocol.h \
shared/helpers.h
-nodist_wayland_backend_la_SOURCES = \
- protocol/fullscreen-shell-unstable-v1-protocol.c \
- protocol/fullscreen-shell-unstable-v1-client-protocol.h
+nodist_wayland_backend_la_SOURCES = \
+ protocol/fullscreen-shell-unstable-v1-protocol.c \
+ protocol/fullscreen-shell-unstable-v1-client-protocol.h \
+ protocol/xdg-shell-unstable-v6-protocol.c \
+ protocol/xdg-shell-unstable-v6-client-protocol.h
endif
if ENABLE_HEADLESS_COMPOSITOR