summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniels@collabora.com>2016-11-28 15:54:06 +0000
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2018-06-20 16:10:12 +0300
commit78a42116ae92f93a01539a785ce95cc478189608 (patch)
treea5487346d5a8d79809476fd1e40a6d01d330946e /Makefile.am
parentf5c96467e31624df842e93cc72f27069b7cb237d (diff)
downloadweston-78a42116ae92f93a01539a785ce95cc478189608.tar.gz
weston-78a42116ae92f93a01539a785ce95cc478189608.tar.bz2
weston-78a42116ae92f93a01539a785ce95cc478189608.zip
tests: Reshuffle IVI layout tests
Rename the IVI tests to be more consistent with the others, and invert the naming of plugin/client to make it slightly more clear what's going to happen. Handle the renaming by using wet_get_binary_path to rewrite the local binaries. As a side-effect, weston.ini ivi-shell-user-interface no longer needs to be given as an absolute path. Signed-off-by: Daniel Stone <daniels@collabora.com> v2: Call ivi-layout.ivi as ivi-layout-test-client.ivi to keep the same name in both the file and the lookup, so that the module map does not need to change the name. Update code comments to reflect the new names. Rename ivi_layout-test-plugin.c to ivi-layout-test-plugin.c. Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Reviewed-by: Daniel Stone <daniels@collabora.com> Reviewed-by: Emre Ucan <eucan@de.adit-jv.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index d2025bc5..3bce47a1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1477,13 +1477,13 @@ ivi_layout_internal_test_la_LIBADD = $(test_module_libadd)
ivi_layout_internal_test_la_LDFLAGS = $(test_module_ldflags)
ivi_layout_internal_test_la_CFLAGS = $(AM_CFLAGS) $(COMPOSITOR_CFLAGS)
ivi_layout_internal_test_la_SOURCES = \
- tests/ivi_layout-internal-test.c
+ tests/ivi-layout-internal-test.c
ivi_layout_test_la_LIBADD = $(test_module_libadd)
ivi_layout_test_la_LDFLAGS = $(test_module_ldflags)
ivi_layout_test_la_CFLAGS = $(AM_CFLAGS) $(COMPOSITOR_CFLAGS)
ivi_layout_test_la_SOURCES = \
- tests/ivi_layout-test-plugin.c \
+ tests/ivi-layout-test-plugin.c \
tests/ivi-test.h \
shared/helpers.h
nodist_ivi_layout_test_la_SOURCES = \
@@ -1500,17 +1500,17 @@ nodist_ivi_shell_app_weston_SOURCES = \
ivi_shell_app_weston_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)
ivi_shell_app_weston_LDADD = libtest-client.la
-noinst_PROGRAMS += ivi-layout.ivi
+noinst_PROGRAMS += ivi-layout-test-client.ivi
-ivi_layout_ivi_SOURCES = \
- tests/ivi_layout-test.c \
+ivi_layout_test_client_ivi_SOURCES = \
+ tests/ivi-layout-test-client.c \
tests/ivi-test.h \
shared/helpers.h
-nodist_ivi_layout_ivi_SOURCES = \
+nodist_ivi_layout_test_client_ivi_SOURCES = \
protocol/ivi-application-protocol.c \
protocol/ivi-application-client-protocol.h
-ivi_layout_ivi_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)
-ivi_layout_ivi_LDADD = libtest-client.la
+ivi_layout_test_client_ivi_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)
+ivi_layout_test_client_ivi_LDADD = libtest-client.la
endif
if BUILD_SETBACKLIGHT