summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmre Ucan <eucan@de.adit-jv.com>2018-05-24 17:08:47 +0200
committerDaniel Stone <daniels@collabora.com>2018-07-22 11:17:40 +0100
commit67546bed04a464d18508265976f2a4b673db565c (patch)
tree89d6eb0473160af0ccd89b714a19e4a21372bc55 /Makefile.am
parentcf4113c629751adcbb9904087932e12b5621219b (diff)
downloadweston-67546bed04a464d18508265976f2a4b673db565c.tar.gz
weston-67546bed04a464d18508265976f2a4b673db565c.tar.bz2
weston-67546bed04a464d18508265976f2a4b673db565c.zip
ivi-shell: use install paths in example config
The example weston.ini file uses source and build directory paths. Therefore, it is only useful when used on the same system that is used to build Weston. We can use install paths instead of build/source paths to fix this problem. v2 changes: - use $(westondatadir) instead of $(datadir) Reported-by: Michael Tretter <m.tretter@pengutronix.de> Signed-off-by: Emre Ucan <eucan@de.adit-jv.com> Reviewed-by: Michael Tretter <m.tretter@pengutronix.de> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3bce47a1..637dd239 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,10 +24,8 @@ weston.ini : $(srcdir)/weston.ini.in
ivi-shell/weston.ini : $(srcdir)/ivi-shell/weston.ini.in
$(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(SED) \
-e 's|@bindir[@]|$(bindir)|g' \
- -e 's|@abs_top_builddir[@]|$(abs_top_builddir)|g' \
- -e 's|@abs_top_srcdir[@]|$(abs_top_srcdir)|g' \
-e 's|@libexecdir[@]|$(libexecdir)|g' \
- -e 's|@plugin_prefix[@]||g' \
+ -e 's|@westondatadir[@]|$(westondatadir)|g' \
$< > $@
all-local : weston.ini ivi-shell/weston.ini